x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE 4.20 Running videos on UML - via mobile phone issue, black output.

Hello,

Issue: Black screen, yet sound plays.

Info on the issue: The UMG video works fine within the editor, and on PC. However, when packaged to mobile, the video no longer works, and results in a blank screen, only the sound plays without the visuals.

About video

  • The video format is .mp4 1920x1080 resolution. 25fps Size:1.6mb Data rate: 2375kb 6 seconds long.

  • Video is placed inside "Movies" folder.

  • Blueprints all working fine (as apparent from editor view / PC)

So in conclusion, the issue only resides when its on mobile Phone: Android - Oneplus5

If there's anything else I can share to help the process of figuring out the issue easier, please inform me. Will highly appreciate any input and help regarding this issue.

Product Version: UE 4.20
Tags:
more ▼

asked Dec 24 '18 at 01:36 PM in Using UE4

avatar image

Nizoo
10 3 2 7

avatar image Nizoo Dec 24 '18 at 08:02 PM

Update: Tried different phones, still same issue.

avatar image Priel71 Dec 25 '18 at 12:24 PM

Hey, try to make sure to rule out codec issues first. Download Handbrake and re-compress the movie file with the android preset selected. Try to package that mp4 file with the project and see if it works. I've had issues myself with files that just playback black, and almost always it was a codec issue. Good luck.

avatar image Nizoo Dec 25 '18 at 09:33 PM

Hey, thanks for your input. I was thinking about the codec being the potential issue. I'm going to give it a try tomorrow or after and update you.

I really hope from the bottom of my heart that its the issue, rather than something related to the compile settings or general project settings.

avatar image Nizoo Dec 28 '18 at 05:37 PM

Unfortunately, even after specifically using handbrake with android presets the same issue remains. I even ventured forth to render my own self-made video for android specifications yet no success.

Any other ideas?

avatar image Priel71 Dec 29 '18 at 03:09 PM

Hmm that's really strange. How about your settings in the android section in the project preferences.. Are you using es2, es3.1... arm7, arm64? Since it's playing back correctly in the editor, I think the best bet now is to see if there's anything in the android build settings which could be wrong or malfunctioning?

avatar image Nizoo Dec 31 '18 at 06:05 PM

As far as I can tell its es2 armv7. I don't really know what they mean, and how it may impact the issue I'm having.

Is there any other particular info I could share?

avatar image Nizoo Jan 08 '19 at 11:43 AM

Okay, I narrowed down the issue to being the Unreal Engine version. In UE 4.15 it works. Its practically the same project settings and android settings.

I still cant tell what exactly is different on UE4.20, but for now im going to try migrating the project files into another empty project in 4.15 and hope for the best.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question