x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unwanted holes in imported FBX mesh

Hello! So I've been working on a school project - trying to combine point clouds renders of a house, surrounded by mesh walls (with auto-collision) to create a game environment. So far I've had success with importing the point clouds using a UE4 plugin, but importing the meshes I made in Autodesk Maya has been a bit of an ordeal.

Here's what the model looks like in Maya:

alt text alt text

Solid, with no holes other than the intended stairway ports. However, when I export the model as an FBX and try importing into UE4, this is the result:

alt text alt text

For some reason the imported mesh now contains holes that start from the intended openings and stretch towards the outer walls. I've placed a player in the scene and walked over these holes - though they it seems like you'd fall through, the mesh is solid and still contains collision. If the mesh was was going to be invisible this wouldn't pose much of a problem, but I need the mesh to show in order to separate the various rooms of the point cloud.

I've tried various import settings (uncombined mesh / no auto-collision / etc.) but nothing gets rid of these holes. I'm new to UE4 so I'm sure I could be missing something simple, but I'm at my wits end trying to deduce what that might be. Any tips or suggestions on how to correct this import issue??

I appreciate any and all help, thank you!

Product Version: UE 4.19
Tags:
3.jpg (181.8 kB)
4.jpg (113.5 kB)
1.jpg (128.2 kB)
2.jpg (153.2 kB)
more ▼

asked Dec 28 '18 at 06:35 AM in Everything Else

avatar image

pockettissues
1 2 2

avatar image HarryHighDef Dec 28 '18 at 11:06 AM

Have you tried inspecting those faces in Maya?

Triangulation?

avatar image pockettissues Dec 29 '18 at 11:02 PM

Yeah, the model was initially exported from Revit and I cleaned up the edges in Maya. The model in the pictures has no extraneous connections, just the edges and vertices necessary to create the various poly shapes.

Do you mean triangulation may be the cause, or that I should try to triangulate the faces to correct it? The original Revit model came pre-triangulated, but I thought deleting the unnecessary edges would save up some processing space - maybe that was a bad call?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Triangulating those objects in Maya then re-importing into Unreal fixed the issue!! I think there was an problem with smoothing groups, but I'm not exactly sure... Either way- it's fixed! Thank you guys for the help!

more ▼

answered Jan 02 '19 at 01:02 AM

avatar image

pockettissues
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

As far as I get this it maybe worth trying importing the mesh directly to the engine, without the plugin, and in the import settings uncheck 'Remove degenerates'. This feature removes ngons out of your mesh. Probably, that's the reason.

more ▼

answered Dec 28 '18 at 02:47 PM

avatar image

script526
1 3 6

avatar image pockettissues Dec 29 '18 at 11:07 PM

I'll try this once I'm back at my computer, thanks! Do you think I could import this way, then re-enable the plugin afterwards? Without it there's no way to render the point cloud data. :S

avatar image script526 Dec 30 '18 at 07:06 PM

Probably. I am not familiar with this plugin. First off, you have to define the reason of your problem. So, the most common reason for removing faces after importing the mesh to the engine is ngons ('degenerates') which the engine removes by default. If the reason is this then you would check if the plugin got options to change the way it imports the mesh.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question