x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'no media player plug-ins are installed and enabled in this project'

Hello, I do not usually turn for help with issues that I am enduring as I can usually resolve the issue or find an answer for myself, however it seems that nobody else is experiencing the issue that I am currently having and searching for it leads to a dead end on Google.

When trying to package my project I get this error:

'LogMediaUtils: Error: Cannot play file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv: no media player plug-ins are installed and enabled in this project'

Plugins However to my confusion media plug-ins are enabled in the project. From the thread that I found it was suggested to try a different format and frame-rate for the source video.

https://forums.unrealengine.com/development-discussion/rendering/118974-%7Bhelp-cannot-play-file-video

I have tried the suggested WMV at 24fps to no luck, my thought was that the engine could not find a valid media player for this specific format automatically. Setting So I have tried setting it manually, this gives me a different error:

'UATHelper: Packaging (Windows (64-bit)): LogMediaUtils: Error: Could not find desired player WmfMedia for file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv PackagingResults: Error: Could not find desired player WmfMedia for file://C:/Users/cplna/Documents/Unreal Projects/Project/Content/Movies/video.wmv'

The source video plays perfectly fine in the editor, only when it comes to packaging does this happen.

My thought is that when set to automatic it cant find a valid player, maybe that is because the video format does not fit the criteria for any of the media players? or maybe its because the media players are not being properly loaded?

I suspect that it is the latter because when I try to manually assign them it gives me the error that it could not be found. I am really not sure why this is the case and it seems far beyond my scope, perhaps this is a bug with the engine?

It should also be noted that I built from source on what I think was a 'promoted' branch, apparently this is version '4.22'. I might try to go to the latest stable release to see if that helps.

Anyway I really hope that this longer post helps resolve this issue and doesn't turn people away. I am truly stuck at a roadblock and hope that I can be helped, thanks for reading!

Product Version: UE Github Master branch
Tags:
asdf.png (35.4 kB)
more ▼

asked Dec 30 '18 at 05:56 PM in Packaging & Deployment

avatar image

cplnathan
1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Bump I have tried installing the latest 4.20 build of the engine, including WmfMedia & Media in the .build.cs file. Not sure if its something I am simply missing because it only fails to package.

more ▼

answered Jan 04 '19 at 12:06 AM

avatar image

cplnathan
1 2

avatar image Yashinski 2 days ago

Have you found a solution for that issue? From my experience unreal just wont accept the fact I enabled the media plugins and wont add it to the list of activated plugins :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question