Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Expression (InOuter || (InClass == UPackage::StaticClass() && InName != NAME_None)) failed ...

I have a project that is a architectural walk through. I am trying to export it to HTML5. I can launch it on my computer and run through the level there. I have gone through the https://docs.unrealengine.com/en-us/...GettingStarted documentation and do not seem to have any issues exporting to HTML5. However, after starting the HTMLLaunchHelper.exe and opening localhost:8000/.html I receive an error, the text of the error is:

Expression (InOuter || (InClass == UPackage::StaticClass() && InName != NAME_None)) failed in D:\Build++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp:2345! Check console for details.

alt text

If I click OK the web page adds 'Initializing Engine...' and just sit there with spinning arrows.

I have tried in both Chrome and Edge, same results. I have tried in Chrome on another computer, same results.

Any assistance would be greatly appreciated!

Product Version: UE 4.21
errors-3.png (19.1 kB)
more ▼

asked Jan 01 '19 at 05:31 PM in Packaging & Deployment

avatar image

6 1 3

avatar image BVvintecc Jan 04 '19 at 11:26 AM

I have exactly the same issue, were you able to solve this? It seems to have started with the latest update of UE 4.21.1, UE4.20 it is still working fine.

avatar image Winthrod Jan 05 '19 at 03:02 AM

I have submitted a bug to Unreal. I have just finished replying to their request for more information, I gave them in depth details of the issue I experienced. They say they couldn't replicate the issue. I added this page in my reply to them saying that I am not the only one having the issue.

It took about a week for them to reply to my initial bug submission so no telling how long it will take for them to follow up. If/when they do I will post their response here.

avatar image BVvintecc Jan 06 '19 at 07:44 PM

This is my original bug post: https://answers.unrealengine.com/questions/862583/view.html?sort=oldest [link text][1]

This is the browser console log: [1]: /storage/temp/264406-consolelog.txt

The console log clearly mentions an error with emscripten.

consolelog.txt (7.5 kB)
avatar image nick.shin STAFF Jan 11 '19 at 08:40 PM

note to self: i'm adding the following link for reference...


seems (so far) when there's a subversion update things break on HTML5. i would like to get to the bottom of this.

winthrod, i believe you were in contact with matt, yes? i'm the html5 dev he mentioned.

internal testing has shown that your zipped uproject builds fine in Developer, Shipping and Shipping For Distribution. so i'm wondering what you and bvvintecc might have on your development environment.

please post what are your PC/Mac specs here.

and if you wish, please PM me your "Editor Session Log" and "Build/Cook/Package" logs. to find your logs, please see:

avatar image Winthrod Jan 12 '19 at 02:56 PM

Yes, I can launch from the editor to my computer and play the level just fine. And if I package it for Windows 64-bit, I can launch and play just fine there. The issue only comes up when when trying to launch from the editor to Chrome, or Edge, or trying to package HTML5 and running the localhost web server.

I have a Dell Precision M7720, running Windows 10 Pro, Xeon Processor, 32 GB RAM, Intel HD Graphics P630 on board with discrete Quadro P4000 video card with 8 GB of RAM.

I will be PM'ing you the Editor Session and Build/Cook/Package logs shortly.

I appreciate your help!

avatar image Winthrod Jan 09 '19 at 11:52 PM

This is the response I received from my bug submission, after giving more information and telling them that you are having the same issue:

Thank you for all of that information. Unfortunately I can still not reproduce the issue, it just is not occurring for me. I spoke to our primary HTML5 developer and they mentioned attempting Firefox instead of Chrome as Firefox is usually quicker with Launch On from UE4 in particular, so he's curious to see if there may be a difference in this case. Please let me know your results and I'll relay it to them to see if they have any ideas.


avatar image Winthrod Jan 12 '19 at 04:04 PM

I just finished sending logs and machine info to Nick above. Hopefully he can determine what is happening. 

One thing I did for testing was created a basic FPS shooter project with no starter content in Engine 4.20.3. I was able to launch in Chrome from the Editor just fine.

I then created the exact same project, basic FPS shooter with no starter content, in Engine 4.21.1. Trying to launch Chrome from the editor gave me the error. Only difference between the two is the engine version. 

I sent a link to Bug Submission of my project file. Their response was:

"internal testing has shown that your zipped uproject builds fine in Developer, Shipping and Shipping For Distribution. so i'm wondering what you and bvvintecc might have on your development environment."

​​​​​​​I haven't modified my development environment - at least not that I am aware of. 

avatar image BVvintecc Jan 15 '19 at 10:42 AM


First of all thank you for looking into this.

Today I received a new desktop computer. I did a clean install of windows 10 professional. Next thing I did was installing ue 4.21.1. During setup it asked for installation of VS2017 which I did. Next I installed Chrome. Next up, I created a blank C++ project and tried to launch for HTML5 chrome.

And I got the same error again as on my other system.

If you want, you can e-mail me on brecht@vintecc.com and we can setup a teamviewer session so you can investigate this issue.

Kind regards, brecht

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I had the same issue a while ago and did not know what to do until I found a notice in the browsers console window, regarding errors produced by some plugins. For me it was the Unreal Studio plugins 'MDL/AxF Importer', 'Variant Manager', 'Variant Manager Content' and 'Sample Mesh Reconstructor', if I remember correctly. Once disabled, I exported it using Shipping Build and it worked.

more ▼

answered Jan 16 '19 at 06:17 PM

avatar image

6 1 1

avatar image Winthrod Jan 17 '19 at 03:22 AM

Bas3008, I had some hope that this was the solution. I disabled the pluggins you mentioned and tried launching Chrome from the Editor. I didn't get an error but Chrome crashed after about two seconds. I then tried exporting to HTML5 and launching a localhost. I received the same error, it is attached.

Then I noticed that most of the plugins were Beta, so I went through and disable most of the beta plugins and tried again. Again, Chrome crashed in about a second after launch. I have attached screenshot of the Output Log. alt text

expression.jpg (48.2 kB)
output-log.jpg (290.6 kB)
avatar image Bas3008 Jan 21 '19 at 05:50 PM

Have you tried packaging with 'Shipping'? For me, the Unreal Studio plugins were the cause of the error, maybe you're also using some additional plugins? Aside from that, I suggest to try the game in Firefox, as it might not crash like Chrome and you may be able to gain more information in the Browser Console.

avatar image BVvintecc Jan 21 '19 at 07:28 AM

Dear Bas3008,

Based on your answer, I disabled some of the experimental plugings + variant manager content + sample mesh reconstructor. The other 2 plugins, I couldn't find in the plugin manager.

alt text

After that, I could launch the C++ project on HTML5 and the error during compilation of webassambly is gone!

I'll investigate more in detail which plugin is actually the cause of the bug and post it here.

Kr, bvvintecc

capture.png (544.4 kB)
avatar image nick.shin STAFF Jan 23 '19 at 04:38 PM

this is an excellent thread -- thank you everyone for helping hunt this down. with HTML5 WASM multithreading work getting plowed in for the 4.22 merge deadline, i wasn't able to help you all with this. but, i'm glad you all were able to narrow down the issues.

i will ask around to see who owns those plugins to ensure those get blacklisted for HTML5. thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

My Conclusion:

On my fresh installed windows: - disabled 'Variant Manager', 'Variant Manager Content' and 'Sample Mesh Reconstructor' and got it working, couldn't find MDL/AxF Importer for some reason -> error disappeared

On my laptop: - the Sample Mesh Reconstructor was already disabled - first disabled the variant manager and variant manager content, launced, but the error persisted - next disabled MDL/AxF importer extra, the error disappeared

My final conclusion would be you need to disable them all as Bas proposed.

Kr, bvvintecc

more ▼

answered Jan 21 '19 at 01:27 PM

avatar image


avatar image Winthrod Jan 31 '19 at 12:53 AM

I apologize for not getting back to this earlier, had to replace my hard drive.

I hate to be the thrower of wrinkles in here but I have additional information to add. I was able to get my test fps project running in HTML5 by disabling the pluggins suggested above. However, after opening my archvis project, the one that started me on this journey, it crashed on me - even after disabling the above mentions plugins.

Needless to say this frustrated me greatly. I had disabled a number of beta plugins previously on the fps project, I was hoping that one of those was causing the crash. So, I documented all the current plugins for Unreal - all 190 some odd of them in a spreadsheet. I marked all Beta plugins and for the fps project that was working in HTML5 I documented whether or not the plugin was enabled or not. Then I disabled plugins in my archvis project ONE at a time and then exported to HTML and tested in a web page. It was the 7th beta plugin that I had to disable before the archvis project would work in HTML5.

The name of the plugin that after disabling allowed my archvis project to run in HTML5 was "MDL/AxF Importer"

I sincerely hope this information is of benefit to someone! And I greatly appreciate everyone's input and suggestions!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We had the same error and solved it by lowering the texture resolution in the HTML5 export profile.,

more ▼

answered Feb 27 '19 at 02:17 PM

avatar image


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question