x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Loading splash screen crashes on openLevel

I've been hitting my head on this hard for a while now and the project has finally come to point where this has to be fixed. I tried this on 4.21 (clean VR project) as well and the problem still exists.

What I'm trying to do is to use OpenLevel from blueprints to go between levels. Streaming levels is not an option since we use different game modes when switched between levels. The splash screen shows correctly but as soon as the next level is loaded, the editor/game crashes. Yes, this happens on build as well. I've done as explained in documentation but that gives same result. I tried show/hide manually, same result.

Log doesn't tell anything either:

 LogGameMode: Display: Match State Changed from InProgress to LeavingMap
 LogGameState: Match State Changed from InProgress to LeavingMap
 LogNet: Browse: /Game/VirtualRealityBP/Maps/HMDLocomotionMap
 LogHMD: Warning:  SteamVR Compositor had an error on present (108)
 LogLoad: LoadMap: /Game/VirtualRealityBP/Maps/HMDLocomotionMap
 LogWindows: Windows GetLastError: The operation completed successfully. (0)

The error code is useless: VRCompositorError_AlreadySubmitted

At this point I'm ready give up and throw the ball to Epic to fix as it seems rather fundamental bug in the VR transition. If you want to try it yourself, here's a take on the blueprint used. alt text It shows the splash screen for 5 seconds just to prove that it works. When you press 'H' (Note that you have to enable input for the blueprint in your level.), next level is loaded.

If there is something I'm doing wrong, let me know so I can fix this. And also, update the documentation part. Much appreciated. Thanks!

Product Version: UE 4.20
Tags:
more ▼

asked Jan 03 '19 at 01:36 PM in VR

avatar image

sf_rimber
1 1

avatar image sf_rimber 6 days ago

Almost two weeks and no real answer for this. Saw this report but in my case the whole editor/game/build crashes. There's gotta to be a fix for a fundamental issue like this. C'mon Epic...

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Did you try not calling ShowSplashScreen at all and enable "Auto Loading Splash Screen"? It should automatically show the splash as soon as you start loading any level, no need to call ShowSplashScreen.

more ▼

answered Jan 03 '19 at 03:19 PM

avatar image

Manoel.Neto
106 2 3 2

avatar image sf_rimber Jan 04 '19 at 02:20 AM

I did. That gave same results. The screen shows up but again when the level is loaded, crash. I think this has something to do with all actors being cleared for the clean load. Unity has handy flag, DontDestroyOnLoad which might solve this but I don't think unreal has it.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question