x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Completely Unused Textures Sitting in Memory (NonStreaming mips)

Hey folks! I'm running up against a very odd situation that's affecting a couple of my games. Basically, it seems like every single texture I add to the content browser gets loaded into the texture pool.

I noticed this when we kept hitting texture pool size warnings basically everywhere in our game--even menus where very little was getting rendered. When I ran Stat Streaming, I saw that the number in NonStreaming mips was huge. That seemed weird to me, so I ran ListTextures and the output log filled up with literally every texture I've added to the game.

To further test this, I created a completely blank level and ran it again. Same thing. This is my Stat Streaming from a level that has literally nothing in it.

alt text

To further test this, I added a very large texture to the game content browser and ran ListTextures. It came up as loaded into the texture pool even though I use it nowhere in the game. I have no sprites or materials that reference it at all.

I have Texture Streaming turned on and only a few of my UI textures are set to "Never Stream". I realize I could just bump up my texture pool and solve this problem, but this feels like something that I should be able to fix. Thanks!

edit: all my textures are Power of 2 sizes so that's not the problem either.

Product Version: UE 4.20
Tags:
stat-streaming.png (23.7 kB)
more ▼

asked Jan 03 '19 at 09:47 PM in Rendering

avatar image

gyrobaal
11 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question