x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to package my game. Alot of engine things are broken ?

Hi! I recently upgraded my sourcebuild version of ue4 from 4.20 to 4.21. I updated my project and tried to package it. Error. In the packaging log a ton of stuff seems to be broken. Engine level stuff. I tried to build the engine from source again to see if i might put a weird character in a file or something. Nothing. The compile completes without a problem. My game compiles fine too. I can play it no problem. But each time i package i get a ton of errors that some engine level stuff is not compiling correctly.

Here are some problems the output log gives me:

C:\Unreal\UnrealEngine\Engine\Source\Developer\MeshBoneReduction\Private\MeshBoneReduction.cpp(138): error C2027: use of undefined type 'FSkelMeshSection'


C:\Unreal\UnrealEngine\Engine\Source\Developer\MeshBoneReduction\Public\MeshBoneReduction.h(10): note: see declaration of 'FSkelMeshSection'


C:\Unreal\UnrealEngine\Engine\Source\Developer\MeshBoneReduction\Private\MeshBoneReduction.cpp(246): error C2065: 'Vert': undeclared identifier


C:\Unreal\UnrealEngine\Engine\Source\Developer\MeshBoneReduction\Private\MeshBoneReduction.cpp(414): error C2143: syntax error: missing ';' before ':'

And many more. I checked all of those files and everything is fine. Keep in mind that if i build the engine using visual studio 2017 everything is working correctly. I attached the packaging log below!

link text

Product Version: UE 4.21
Tags:
new-3.txt (410.0 kB)
more ▼

asked Jan 04 '19 at 05:53 PM in Packaging & Deployment

avatar image

Gunschlinger
116 16 23 41

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question