x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I get less framerate on Vulkan than OpenGL4 with NVIDIA hardware and drivers

I've been developing in UE4/C++ on Funtoo (a variant of Gentoo Linux) using OpenGL 4 without any issues for a few years. On the Minimal_Default map I always get 120 FPS even on lower spec graphics cards with -opengl4. Since 4.21 switched to Vulkan as the default graphics API I decided to give it a shot. When I run the engine with Vulkan I'll get 75 FPS on the Minimal_Default map which is a bit unexpected.

Is this because Vulkan layer in UE4 not optimized or it's happening due to something else?

As a side note, I am running UE4 under X/i3wm/Compton, nvidia drivers version 415.25, vulkan loader version 1.1.77.0, and vulkan headers version 1.1.82.0.

Product Version: UE 4.21
Tags:
more ▼

asked Jan 06 '19 at 02:57 PM in Using UE4

avatar image

NuLL3rr0r
27 5 7 10

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

OK! for anyone coming across this issue: I solved the issue by adding NVPTX to LLVM_TARGETS Extended USE flag inside /etc/portage/make.conf.

On my previous installation, I had this Extended USE flag enabled. But, I thought it was unnecessary. OK, what does it do?

It is being used by Mesa for I guess building shaders or something like that, though I am not sure what's the exact usage; so I had to:

Change:

  LLVM_TARGETS="BPF X86"

To:

 LLVM_TARGETS="BPF NVPTX X86"

And:

  $ emerge -a --oneshot `equery depends llvm|awk '{print " ="$1}'`

 These are the packages that would be merged, in order:
 
 Calculating dependencies... done!
 [ebuild   R    ] sys-devel/llvm-7.0.0-r1 
 [ebuild   R    ] sys-devel/llvmgold-7 
 [ebuild   R    ] sys-libs/libcxxabi-7.0.0 
 [ebuild   R    ] sys-devel/lld-7.0.0 
 [ebuild   R    ] sys-libs/libcxx-7.0.0 
 [ebuild   R    ] sys-devel/clang-7.0.0 
 [ebuild   R    ] media-libs/mesa-18.2.4 
 [ebuild   R    ] sys-libs/compiler-rt-7.0.0 
 [ebuild   R    ] dev-util/lldb-7.0.0 
 [ebuild   R    ] sys-libs/compiler-rt-sanitizers-7.0.0 
 [ebuild   R    ] www-client/firefox-64.0 
 
 Would you like to merge these packages? [Yes/No] 
 

Did a reboot and now I'm getting 120 FPS on -vulkan :)

more ▼

answered Jan 11 '19 at 12:47 PM

avatar image

NuLL3rr0r
27 5 7 10

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question