x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.4.0 Fails to launch

I posted a question a few days ago but believe I put up the wrong log file which wouldn't have shown off the main problems I'm having. To keep it short, basically when I go to launch the engine/editor through the launcher, the loading splash screen appears for a few seconds before disappearing...that's it. Nothing appears, no obvious error message, just nothing.

Would really appreciate any help as I've tested on another PC and it had no issues but I really need it on my home PC.

Thanks

log and dxdiag

Product Version: Not Selected
Tags:
error log.zip (8.0 kB)
more ▼

asked Aug 20 '14 at 11:29 AM in Installation & Setup

avatar image

NOSdog
56 2 5 6

avatar image TJ V ♦♦ STAFF Aug 21 '14 at 06:04 PM

Hi NOSdog,

See if there are any solutions listed on the link below that may help. If you still can't fix the issue, could you also post your Verbose Logs? Directions on how to find those is listed towards the bottom of that wiki link.

https://wiki.unrealengine.com/Troubleshooting_Launcher_Problems

avatar image Stephen Ellis ♦♦ STAFF Aug 21 '14 at 10:18 PM

Hi NOSdog,

Our apologies, the above link is for Launcher problems, but your launcher sounds to be working fine and the issue is with the Editor.

Can you ensure that your graphics card is updated to the latest drivers?

Thanks

avatar image NOSdog Aug 22 '14 at 08:18 AM

Hi,

Thanks for replying. Yes I believe the problem is editor related but I am going to attach another log to this message which I believe is launcher related. I've double checked and appear to be running the latest drivers for my video card (Geforce 340.52).

The only thing that is different now after my most recent re-install is that it sits on the editor loading splash screen for a lot longer sometimes than it used to. As though it's making some progress but still nothing comes as a result.

Any help would be greatly appreciated because while normally I can trouble shoot my way out of most issues I just have no idea what could be going on here. All I can understand from the logs is that maybe it's something to do with either this line;

LogWindowsTextInputMethodSystem:Error: Terminating failed while unadvising the language notification sink from the TSF source.

or this line

[ 0]BuildDataGenerator: FATAL ERROR: EBuildPatchInstallError::ApplicationClosing,

But really I have no idea. I included a log from the launcher though. Thanks.

NOSdog error log

avatar image gmpreussner STAFF Aug 25 '14 at 04:17 PM

NOSdog, I can't help you with the Launcher problem, but I'm curious about the crash log you posted in the question (the Editor log file).

Maybe a silly question, but does your home PC have a network adapter installed and is it enabled?

avatar image gmpreussner STAFF Aug 25 '14 at 04:18 PM

Also, can you tell me whether the Editor crashes consistently with the log you posted, or only sometimes? Is the error at the bottom of the log always the same?

avatar image NOSdog Aug 26 '14 at 12:57 PM

Hi,

Yes my computer does have a network adapter which is enabled and working as far as I can tell. I disabled and re-enabled it as well but it made no difference.

My crashing issues are also very consistent, I've attached a picture which compares the last few lines from 3 logs taken from completely different days and except for one minor and probably insignificant difference on one line they all appear to be exactly the same error.

Thanks for your time. log errors

log dates.png (285.9 kB)
avatar image gmpreussner STAFF Aug 26 '14 at 05:18 PM

Hmm, sadness. I have not seen this particular problem before. Would you be able to compile the Editor from source code, so we can debug this in Visual Studio? Unfortunately, the error messages do not contain enough details as to what exactly is going wrong.

avatar image NOSdog Aug 27 '14 at 02:07 PM

I'm compiling as I type this, hopefully I haven't screwed up the process and will post results once it's done.

avatar image gmpreussner STAFF Aug 27 '14 at 03:23 PM

Ok, excellent. If you use IRC, please come see me in #unrealengine on Freenode. My nickname is Epic|j3rky. You can also use this web based chat client: http://webchat.freenode.net/

It will be faster to iterate in chat than here, thanks!

avatar image NOSdog Aug 27 '14 at 09:40 PM

Thanks I'll use that from now on but I just thought I'd post a screenshot of the first immediate problem I ran into when trying to launch/debug the compiled build. This message pops up almost instantly when trying to launch. message

debug.png (24.0 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Holy crap I got it working!!

After googling the above debugging error, someone had posted an answer for a similar problem that involved running cmd.exe and entering the following two lines.

1) netsh winsock reset catalog

2) netsh int ip reset reset.log hit

I was rebuilding the source code version at the time but decided to try launching through the launcher just for kicks and what do you know it worked!

Thanks for all the help/advice, hopefully this isn't a one off and it's sorted my issues for good.

Cheers.

more ▼

answered Aug 28 '14 at 01:20 PM

avatar image

NOSdog
56 2 5 6

avatar image Zac Sigmon Mar 26 '16 at 04:30 PM

The 2 commands fixed a launcher crash issue for me as well - lifesaver

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question