x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Third party Mono related error when remote building for iOS

After upgrading to UE4.21, when trying to launch on iOS device I got following errors.

 LogPlayLevel:   [Remote] Executing build
 LogPlayLevel:     Setting up Mono
 LogPlayLevel:     Building TLM...
 LogPlayLevel:     2019-01-09 05:35:44.571 defaults[1264:13408]
 LogPlayLevel:     The domain/default pair of (com.apple.dt.Xcode, IDEBuildOperationMaxNumberOfConcurrentCompileTasks) does not exist
 LogPlayLevel:     Running command : Engine/Binaries/DotNET/UnrealBuildTool.exe TLM IOS Development -deploy -SkipRulesCompile -XmlConfigCache=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/Engine/Intermediate/Build/XmlConfigCache.bin -Log=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/Engine/Programs/AutomationTool/Saved/Logs/UBT-TLM-IOS-Development_Remote.txt -Manifest=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/Intermediate/Remote/TLM/IOS/Development/Manifest.xml -Project=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/TLM.uproject -Project=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/TLM.uproject -NoUBTMakefiles -remoteini=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM -skipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Disabled -NoHotReload -ignorejunk -CreateStub -NoUBTMakefiles -ImportProvision=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/Intermediate/Remote/TLM/IOS/Development/TLMDevelopment.mobileprovision -ImportCertificate=/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/Intermediate/Remote/TLM/IOS/Development/Certificate.p12 -ImportCertificatePassword=A
 LogPlayLevel: Warning:     WARNING: -SkipDeploy conflicts with -Deploy - ignoring
 LogPlayLevel:     Building UnrealHeaderTool...
 LogPlayLevel:     While compiling /Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/Engine/Intermediate/Build/BuildRules/UE4Rules.dll:
 LogPlayLevel:     (0,0) : error : Cannot open assembly '/Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/Engine/Build/BatchFiles/Mac/../../../Binaries/ThirdParty/Mono/Mac/lib/mono/4.5/mcs.exe': No such file or directory.
 LogPlayLevel: Error:     ERROR: Unable to compile source files.
 LogPlayLevel:            (see C:\Work\UnrealEngine4\Engine\Programs\AutomationTool\Saved\Logs\UBT-TLM-IOS-Development_Remote_UHT.txt for full exception trace)
 LogPlayLevel: Error:     Error: UnrealHeaderTool failed for target 'TLM' (platform: IOS, module info: /Users/harvey/UE4/Builds/HARVEY/C/Work/UnrealEngine4/TLM/Intermediate/Build/IOS/TLM/Development/TLM.uhtmanifest, exit code: OtherCompilationError (5)).
 LogPlayLevel:   [Remote] Downloading C:\Work\UnrealEngine4\Engine\Programs\AutomationTool\Saved\Logs\UBT-TLM-IOS-Development_Remote.txt
 LogPlayLevel: Took 565.2822311s to run UnrealBuildTool.exe, ExitCode=7
 LogPlayLevel: Error: ERROR: UnrealBuildTool failed. See log for more details. (C:\Work\UnrealEngine4\Engine\Programs\AutomationTool\Saved\Logs\UBT-TLM-IOS-Development.txt)
 LogPlayLevel:        (see C:\Work\UnrealEngine4\Engine\Programs\AutomationTool\Saved\Logs\Log.txt for full exception trace)
 LogPlayLevel: AutomationTool exiting with ExitCode=7 (7)
 LogPlayLevel: Completed Launch On Stage: Build Task, Time: 568.950702
 LogPlayLevel: BUILD FAILED
 PackagingResults: Error: Deployment failed! Unknown Error

Besides UE, I've also upgraded my remote MacOS to Mojave and XCode to 10.1. It's seems that there is missing some files related to Mono third party, but there is it supposed to be?

Product Version: UE 4.21
Tags:
more ▼

asked Jan 09 '19 at 01:52 PM in Packaging & Deployment

avatar image

shh---
104 1 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Downloaded Mono from here:

https://www.mono-project.com/download/stable/#download-mac

And installed on remote MacOS. Passed through the point of error.

more ▼

answered Jan 09 '19 at 02:54 PM

avatar image

shh---
104 1 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question