x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.21] Proxy LOD generator producing black texture

I'm currently trying to use the proxy LOD tool to reduce some building meshes. It works perfectly for some models, but seemingly at random will start producing black albedo textures for certain meshes. Other meshes still work, and perhaps most confusingly, a mesh that worked at one time can suddenly stop working and will start producing black proxy models when re-merged. Even after restarting the editor, deleting the previous proxy mesh, etc.

I've found that after exporting and re-importing the mesh, the issue will not appear on the re-imported mesh. But obviously this isn't a good solution. I've also tried tweaking essentially every setting in the proxy merge tool, to no result. Sometimes meshes will suddenly start turning black after being merged twice with the exact same settings. I've also noticed some meshes turn back, and start being perfectly fine again.

Here you can see the results for one building: Imgur It's not effected by lighting, the blackness is in the albedo itself Imgur Imgur

EDIT: It's also not unresolved geometry, just to clarify. Changing the unresolved geometry color to red results in this: (Different building, but it's the same for all of them) Imgur

Product Version: UE 4.21
Tags:
more ▼

asked Jan 09 '19 at 06:25 PM in Bug Reports

avatar image

Axton9
1 2

avatar image Jeff A ♦♦ STAFF Jan 11 '19 at 01:11 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question