x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Attributes system - failing to load curve table

Hi, I've been trying to set up the Attribute System from UE4's GameplayAbilities system, and I mostly followed this tutorial: https://forums.unrealengine.com/community/community-content-tools-and-tutorials/116578-comprehensive-gameplayabilities-analysis-series

However, many issues that I've been experiencing weren't covered in the tutorial, and no one there has responded to my questions, so I wanted to ask here. The problem is that I am trying to use their own system which has a lot of ridiculously cumbersome ways of loading some default values from a Curve Table that is written in DefaultGame.ini

It looks like this:

     for (const FSoftObjectPath& AttribDefaultTableName : GlobalAttributeSetDefaultsTableNames) {
 ......
          UCurveTable* AttribTable = Cast<UCurveTable>(AttribDefaultTableName.TryLoad());


Basically, there is an FSoftObjectPath& and we are trying to use that value to TryLoad() a Curve table. I have written the table's address in DefaultGame.ini: (my module name is Zangies but game folder is Maelstrom)

[/Script/GameplayAbilities.AbilitySystemGlobals] GlobalAttributeSetDefaultsTableNames=/Game/Content/GameplayAbilities/AttributeTables/BAS_Curve.BAS_Curve +GlobalAttributeSetDefaultsTableNames=/Game/Content/GameplayAbilities/AttributeTables/TestCurve.TestCurve

The rest of the function successfully detects that there are two curve tables and loops through them, but is not actually able to get anything back when it loads them.

This is the format that the tutorial gave me.

But when I have tried to test this, it returns nothing. I have tried other formats of checking if the TryLoad() return is valid, and I'm getting nothing.

What can I do? I don't have any experience with this kind of loading from ini files, and I am really at a loss as to how to troubleshoot this.

Product Version: UE 4.21
Tags:
more ▼

asked Jan 10 '19 at 02:28 PM in C++ Programming

avatar image

SamPanda
1

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question