Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Mouse Y doesn't work anymore

It seems that in 4.21 the mouse input for the y-axis doesn't work anymore. I did set it up in the input section alt text

and in my character blueprint I set up a simple graph for the LookUp functionality alt text

in 4.20 it all worked perfectly. The weird thing is if I show the mouse cursor, the y-axis seems to work. Does anyone have a suggestion?

Product Version: UE 4.21
unbenannt.png (5.1 kB)
unbenannt1.png (96.6 kB)
more ▼

asked Jan 10 '19 at 07:59 PM in Blueprint Scripting

avatar image

426 38 47 143

avatar image Tuerer Jan 10 '19 at 08:10 PM

What if you create a standard fps or tps project, does it work there?

avatar image Jacky Jan 10 '19 at 08:18 PM

Make sure you aren't using the same input or axis value anywhere else, i.e. Level BP which can override. If that's the case you can disable "Consume Input" in that input or axis' Details in wherever else you are using it.

avatar image ThompsonN13 Jan 10 '19 at 11:07 PM

could also be your characters setup. for example the inherit pitch and use control rotation options. i would use a print string instead of the add controller pitch to confirm if the axis event if firing. once you ensure that the event if firing you will know if the issue lies elsewhere.

avatar image Pseudocorpus Jan 11 '19 at 02:16 PM

Thank you for your comments!

@Tuerer: It works in the TPS example project

@Jacky: I don't know exactly what you mean by "Consume Input" but I checked my Blueprints and the Character Blueprint seems to be the only one which uses the InputAxis-Event(s) ... and each of the events is only used once.

@ThompsonN13: I disabled/enabled the "Inherit pitch" and "use control rotation" options for my camera boom without any effect. I tucked a print string behind the event and it always seems to fire with an output of 0.0 ... even if I don't move the mouse at all.

It is weird that the yaw works but the pitch doesn't. :-/

avatar image Tuerer Jan 11 '19 at 02:20 PM

If it works in another project, that it's certainly not a 4.21 build or hardware issue; something in your project must be interfering with Y movement.

avatar image Jacky Jan 11 '19 at 04:43 PM

alt text

Also i agree with Tuerer. If you used even the axis value like the one in the screenshot in a higher priority BP it is going to prevent you from using it in your player character.

input.jpg (26.7 kB)
avatar image Pseudocorpus Jan 12 '19 at 01:28 PM

Thx... yeah the mouse Y stuff doesn't get called anywhere in my blueprints. Maybe I have to check my C++ classes again.

You're right, it is no inherent problem with the 4.21 build. It is just that the 4.21 apparently did something new in the source code (maybe something with the input) that interferes with my code and/or vice versa. I checked my project with 4.20 again and it all works there.

I think I have to study the 4.21 release notes. Thank you guys.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok found the solution.

I have a function that reads the mouse sensitivity from a config file and sets it via console command

alt text

Apparently the console command changed in 4.21 so that you don't enter one value for the sensitivity anymore but a x- and a y-value

alt text

In my case the y-value must have been set to 0.0 because it wasn't specified ... now it works. Thanks again for your help.

graph.png (143.5 kB)
more ▼

answered Jan 12 '19 at 03:18 PM

avatar image

426 38 47 143

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question