x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

FBX import has flipped normals, how can I fix it?

Hi there,

I'm having an issue with an FBX file I'm trying to import into my level. When I import it, the normals are flipped, and I can't seem to find a fix for it. I've tried everything suggested to me, including flipping the normals in 3DS Max before exporting, but that doesn't help me in this situation, since when I try to bake the lighting, the whole object goes black.

Is there any way for me to invert the normals in Unreal? At this rate I feel like I may need to remodel the object since I can't find a solution that works for me.

Thanks!

Product Version: UE 4.20
Tags:
more ▼

asked Jan 10 '19 at 09:23 PM in Rendering

avatar image

Nospar
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi!

If your object turns completely black after lightbuild it has problems with its lightmap (usually not existing/wrong uv channel!!) and not normals... usually when you have flipped normals your mesh/faces starts to glow/emit light!! ...anyway you should be able to fix it in your 3d app!!

In Unreal usually what can help is to uncheck use mikktspace in your object's properties...

more ▼

answered Jan 10 '19 at 09:41 PM

avatar image

Makigirl
1.2k 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Okay, so there are two issues going on there. First off, if your mesh is importing with the normals inverted, there's a good chance that the scale transforms have not been applied. In Blender, you fix this by pressing Ctrl-A while in Object Mode and then select Scale, and it resets your model's scale to 1.0 (100%) across all axes. I'm not familiar with 3ds Max, but you'll want to go through whatever procedure you use to get your scale transforms at 100% across all axes. If you haven't already, try that and see if it doesn't eliminate the issue.

If that's not the issue, and you're still importing reversed normal meshes that render black, you can fix this by editing the mesh properties in Unreal (Ctrl-E or double click the icon in the content browser). Go under LOD 0 settings and check 'Recalculate Normals' and change the Source Lightmap Index from '0' to '1.' That's worked for me in the past when I've had that problem, however, the first option about fixing your scale should solve the problem without requiring you to hack the mesh properties at all.

more ▼

answered May 23 '19 at 05:54 AM

avatar image

Ianu_Gor
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question