x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level sequence values change on play.

I've noticed that no matter what I set my first keyframe value to be, on starting game it sets to some number that I have no clue where it came from. Here our my values in editor mode. alt text And here they are a second after hitting play. alt text The camera actor in the scene mirrors these changes, going from the correct values to the incorrect only a second after hitting play. I've also messed around by changing these values in both the actor and the sequence however no matter what I try it still resets to these values. I've also tried setting the sequence to both keep state and restore state which didn't affect anything. Its not just the camera alone I was messing around with a physics constraint and had set its mobility to static and now it won't set back to movable.

Is there something in the sequencer I'm just missing?

Product Version: UE 4.21
Tags:
levelseq.png (23.7 kB)
levelseq2.png (22.5 kB)
more ▼

asked Jan 11 '19 at 04:28 AM in Using UE4

avatar image

themdubs
1 2 2

avatar image Max.Chen STAFF Jan 23 '19 at 07:32 AM

How are you taking a snapshot of these values when you hit PIE? I wouldn't necessarily rely on those values a second after hitting play. Can you print the position of the camera component to a debug string to see if it is indeed different?

The values you're seeing could also be the spawned position of the camera before sequencer starts playing. If you close down sequencer in editor, does the position of the camera match the image "a second after hitting play"?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question