x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error remote build iOS xcode 10.1

Guys I'm having seriuos Trouble Right now. I am remote-Building my iOS build using UE 4.18.3 and xcode 10.1 using iOS 12.1 SDK. I get this error:

 UATHelper: Packaging (iOS):   /Users/aleksandar/UE4/Builds/LAPTOP-BB7FO20G/C/Program Files/Epic Games/UE_4.18/Engine/Source/Runtime/CoreUObject/Public/UObject/UnrealType.h:3285:37: error: lambda capture 'LocalMapLayoutForCapture' is not used [-Werror,-Wunused-lambda-capture]
 UATHelper: Packaging (iOS):   
 UATHelper: Packaging (iOS):                           [LocalKeyPropForCapture, KeyPtr, LocalMapLayoutForCapture](void* NewElementKey)
 UATHelper: Packaging (iOS):   

I need to update my iOS app (already public) BUT apple now REJECTS build with UE4.18.3 and the older iOS 11 SDK which worked until now!!!

Does anyone know how to get rid of this error because I NEED to build it with iOS SDK 12.1 - apple already rejected the version build with the older SDK. I tried opening the project with UE4.20.1 but I cannot successfully do the transfer.

Please any help. This is too frustrating

Product Version: UE 4.18
Tags:
more ▼

asked Jan 12 '19 at 02:27 PM in Packaging & Deployment

avatar image

Aleksandro
207 7 16 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

for anyone having the same issues:

@iktomi Thanks the clang setting for the lambda is working. We need to add this in IOSPlatformCompilerPreSetup.h as well as MacPlatformCompilerPreSetup.h (look for those in engine Folder,open These and edit them in visual Studio) Just add this at the end of those files:

// Apple LLVM 9.1.0 (Xcode 9.3) #if (clang_major > 9) || (clang_major == 9 && clang_minor >= 1) #pragma clang diagnostic ignored "-Wunused-lambda-capture" #endif

https://answers.unrealengine.com/questions/776429/view.html

more ▼

answered Jan 14 '19 at 04:48 PM

avatar image

Aleksandro
207 7 16 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question