x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

compile failed - Unable to load module 'ScriptGeneratorPlugin' - 0 instances of that module name found.

ue4 asks me 2 recompile the module b4 my char class will appear in the content browser howevr it fails evrytime I'm trying 2 compile it
I got w7 and vs2017 with c++ and ue4 components
I used this tutorial 2 setup vs 4 ue4
some1 knows what's going on here? alt text alt text alt text

Product Version: UE 4.21
Tags:
ue1.png (601.6 kB)
ue2.png (306.4 kB)
ue3.png (78.5 kB)
more ▼

asked Jan 16 '19 at 03:17 PM in C++ Programming

avatar image

j3lly_m3lly
5 2 5

avatar image ZeroParadigm Jan 16 '19 at 08:24 PM

Hi @j3lly_m3lly , have you tried closing the editor and building from Visual Studio?

avatar image j3lly_m3lly Jan 16 '19 at 09:15 PM

just tried that and it failed :< alt text

alt text

ue4.png (42.0 kB)
ue5.png (4.2 kB)
avatar image ZeroParadigm Jan 16 '19 at 11:59 PM

Typically you will see this message when you are including a plugin or module that doesn't exist or is misspelled in your build files. I'm not in front of the codebase right now but my inclination is that the script generator plugin has been removed or refactored. Look at your project's .uproject file, and your game target.cs files to find any reference of this module. If you find it, just remove that from the list of included modules/plugins

Let me know what you find.

avatar image ZeroParadigm Jan 17 '19 at 05:40 AM

After looking more at this... ScriptGeneratorPlugin is definitely still in the codebase. If you still need help, you gotta show us the .uproject and build/target.cs files you are using

https://github.com/EpicGames/UnrealEngine/tree/release/Engine/Plugins/ScriptPlugin/Source/ScriptGeneratorPlugin

avatar image j3lly_m3lly Jan 17 '19 at 08:30 AM

:< alt text

404.png (381.4 kB)
avatar image j3lly_m3lly Jan 17 '19 at 08:55 AM

I made my repo and uploaded those files here:
https://github.com/j3lly-m3lly/ue4c-

btw is it possible that it may b caused by some ue4 plugins that r incompatible 2gether 4 example?
I added some of them when I made this project

avatar image j3lly_m3lly Jan 20 '19 at 04:47 PM

mayb my vs needs c# components?
I thought only c++ will b needed so it doesn't have c# components

avatar image j3lly_m3lly Jan 23 '19 at 04:52 PM

ehh so it looks like I'm totally screwed at this point(...) :/
only thing left is 2 remove plugins and if it doesn't work, I will have 2 reinstall whole ue4 and see if that works by any chance >,o

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question