x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fatal error importing via Datasmith (memory allocation)

Hi guys,

Simply put: I wanted to import a Revit file via Datasmith in to UE4. I tried everything, but it keeps crashing while doing this. Maybe it has to do with the model itself (size: 150 MB), because basic files like the default Revit file that comes along with the program, works just fine.

The error says: Fatal error: [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line:200] Ran out of memory allocating 3990934 bytes with alignment 0

First sytem (desktop): i7 4770K @ 4.1 GHz 32 GB DDR3 250 GB SSD + 2 TB HDD 1080Ti

Second system (laptop) HP Omen i7 7820 HK @ 2.9 GHz 32 GB DDR4 500 GB SSD + 1 TB HDD 1080

Third sytem (desktop): i7 5820K@ 3.3 GHz 16 GB DDR4 250 GB SSD + 2 TB HDD R9 280

The error keeps coming at my desktops. The laptop just crashes with BSOD (DPC Watchdog Violation)

I already have the latest drivers + software. Talking about Revit 2019, Unreal 4.21.1, latest exporter, windows 10, nvidia driver etc. Also tried in a brand new project, still no results.

The udatasmith file is 11 MB

Can someone help? Thanks!

Product Version: UE 4.21
Tags:
more ▼

asked Jan 16 '19 at 04:36 PM in Using UE4

avatar image

Furkan_X
11 1 2

avatar image Beyond Matter Jan 22 '19 at 06:37 PM

I got the same isse here. Importing a 3ds Max file.

 Fatal error: [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 200] Ran out of memory allocating 69493860 bytes with alignment 0

Any idea why this is happening?

avatar image Stephen Ellis ♦♦ STAFF Jan 22 '19 at 10:38 PM

If you increase your memory, it may not crash anymore. For example, Furkan shared his assets and it did not crash on our hardware, but we did note that the import used a lot of memory, so we logged a bug report to investigate this. https://issues.unrealengine.com/issue/UE-68659. There may be optimizations we can make on our end, but we don't have a timeline for that yet.

Specifically however, Furkan's issue was with a Revit import. For a 3ds Max file, we'd also like to have a test case, so please follow the link I provided in my other answer a report this issue, along with the asset that reproduces it.

Thanks

avatar image Furkan_X Jan 23 '19 at 09:29 AM

You can vote here:

https://issues.unrealengine.com/issue/UE-68659

The whole issue is the model being complex. My model has a lot of circles/pipes in it, so the polygons are a bit too much to handle (even for 32 gb). How much gb ram do you use? Maybe i can try to export it on my pc for you :)

avatar image Beyond Matter Jan 23 '19 at 12:23 PM

I got 32 gb of ram on my pc. My scene is an ArchViz scene so it is indeed a bit heavy on the polygons, but nothing really over the top (only a one bedroom apartment) so I believe Datasmith should be able to handle this as it is designed to import complex architectural stuff. I might be looking into upgrading my memory but would of course appreciate any fix on the Unreal side to this as well:)

Thanks, I upvoted the report:)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Furkan.

I've looked up your CrashReports. It looks like the one from the laptop is a basic OutOfMemory crash.

The one from your other system is a little more unique to Datasmith, but still a memory issue.

 Fatal error: [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 200] Ran out of memory allocating 2209056 bytes with alignment 0
 
 UE4Editor-DatasmithImporter!2c1c0000  + ac384
 UE4Editor-DatasmithImporter!2c1c0000  + 6fc09
 UE4Editor-DatasmithImporter!2c1c0000  + 6fa5e
 UE4Editor-Core!FQueuedThread::Run() [ThreadingBase.cpp:455]
 UE4Editor-Core!FRunnableThreadWin::Run() [WindowsRunnableThread.cpp:76]
 UE4Editor-Core!FRunnableThreadWin::GuardedRun() [WindowsRunnableThread.cpp:33]
 KERNEL32!85da0000  + 17e94
 ntdll!870a0000  + 6a251

11MB is not a large file, so we'd like to investigate further if there is a bug with Datasmith behind this, but we'll only be able to determine that if you'd be willing to share the file so we can test it.

We have a specific support site for Unreal Studio - https://unrealstudiohelp.epicgames.com/s/case-community-page -please file a bug report here and upload the file, and we will follow up on your support ticket.

Thanks

more ▼

answered Jan 16 '19 at 04:57 PM

avatar image

Stephen Ellis ♦♦ STAFF
11.5k 322 32 480

avatar image Furkan_X Jan 16 '19 at 05:25 PM

Thanks Stephen. It is a very weird issue. Hope we can solve it together. The file itself is 11 MB, but the assets are 3.25 GB

I posted the issue on the link you've provided including the complete file. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question