x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Get Game Mode" and "Get Player Controller" nodes don't show up

So, I've an UObject created in C++ and I'm trying to script in blueprint a UFunction with the BlueprintNativeEvent specifier. Thing is, the nodes "Get Game Mode" and "Get Player Controller" don't show up on the graph. A screenshot of the blueprint event graph

A screenshot of the blueprint event graph I tried unchecking the context sensitivity but it doesn't work. If I try to copy the nodes from another actor and paste them on this object I only get the message "conflicting nodes substituted during paste!" even if there are no nodes on the graph.

Product Version: UE 4.20
Tags:
screenshot-1.png (63.0 kB)
screenshot-2.png (33.6 kB)
more ▼

asked Jan 19 '19 at 09:22 PM in Blueprint Scripting

avatar image

Lazy_
22 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The issue is that it inherits from UObject, not AActor or such.

GetGameMode is part of UGamePlayStatics

http://api.unrealengine.com/INT/API/Runtime/Engine/Kismet/UGameplayStatics/GetGameMode/index.html

It requires WorldContextObject to function.

And here someone seems to have been able to "fix" the issue

https://answers.unrealengine.com/questions/468741/how-to-make-a-blueprint-derived-from-a-uobject-cla.html

Or just inherit from AActor instead or choose another approach.

more ▼

answered Jan 21 '19 at 01:07 AM

avatar image

JoSf
253 2 6 9

avatar image Lazy_ Jan 23 '19 at 07:45 PM

thank you, I tried the fix you posted and it seems to work just fine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question