x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Errors when trying to cook content for Windows

We are having problems cooking our game content for Windows 64-bit. This is the stack trace I get when I click the "Cook Content" option: alt text

I can see it says "Failed to identify the asset package that '...' belongs to" and I would like to know how I can solve this.

I would like to say this also only happens when nativization is enabled, but we would like to know if there is another way to fix this other than disabling nativization.

Product Version: UE 4.21
Tags:
more ▼

asked Jan 22 '19 at 03:19 AM in Packaging & Deployment

avatar image

Lupix
86 1 4 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Is this 4.21.2, the newest update? That seems to give me an assertion failure (perhaps a bug).

If not that version, the usual thing to try is exit UE4 editor, delete (or if you're unsure, move to another folder) Binaries, Build, and Intermediate folders (maybe the Saved too, but you would lose saved games, for example), restart UE4 editor and try again. Sometimes that works.

more ▼

answered Jan 23 '19 at 04:58 PM

avatar image

Todd.Vance
32 1 5

avatar image Lupix Jan 29 '19 at 12:46 PM

We have tried deleting the folders you mentioned and we have restarted the editor, but unfortunately that didn't change anything. I think it's fixed now though, and if I can tell with certainty that it is fixed, I will post the answer here. Thank you for the reply anyway.

avatar image paradoc Feb 11 '19 at 07:50 PM

are you able to post your fix for this yet? i've just migrated from 4.18 to 4.21.2 and am having the same issue when nativizing blueprints specifically for a custom enum that was created in blueprints.

avatar image Lupix Feb 12 '19 at 05:30 PM

Hey, paradoc. No, unfortunately we have not found a fix without disabling nativization as of now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question