Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why whenever I create a new C++ class for my Blueprint Project does it never allow me to enter that project again???

All I did was Download VS2017 after creating a new C++ class, close and try to reopen the project.....

Now my project refuses to open saying I need to rebuild my source manually after it was unable to build...........

I tried doing it with a new project and I get the same results...I'm just trying to add a tiny bit of code and now my project refuses to open.

Another thread recommended deleting script found in a modules folder but I cant locate that..... As far as I'm concerned the modules folder is a myth and a lie.

Product Version: UE 4.19
more ▼

asked Jan 23 '19 at 09:46 PM in C++ Programming

avatar image

40 1 5 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Are you sure that installed Game Developement With C++ on Visual Studio Installer?

alt text

If not, can you provide log files?

more ▼

answered Jan 23 '19 at 10:36 PM

avatar image

145 7 11 13

avatar image AXlOM Jan 23 '19 at 10:42 PM

Thanks I'm going to reinstall ensuring that option is enabled!

avatar image AXlOM Jan 23 '19 at 11:16 PM

Ok still the same problem, here is my log i think? Never posted my log beforelink text

I definetly made sure to enable the option you specified but it still doesnt open

logs.txt (36.4 kB)
avatar image AXlOM Jan 23 '19 at 11:43 PM

I was able to open the Project in VS2017 finally, after reinstalling with "Game development with C++ enabled", still unable to open the project in UE4 though.

Would super appreciate any help!

avatar image Khubur Jan 23 '19 at 11:50 PM

As you can see in the logs there is an error message displayed;

ERROR: Windows SDK v8.1 must be installed in order to build this target.

After trying to build the solution, recap to install Windows SDK 8.1 on Visual Studio Installer again.

avatar image AXlOM Jan 24 '19 at 12:13 AM

Thanks a bunch, I have heard other people mention Windows SDK V8.1 before in response to similar problems so that sounds about right.

What is Windows SDK V8.1? Your not talking about the operating system right?

avatar image AXlOM Jan 24 '19 at 12:16 AM

Nevermind, Downloading the 8.1 SDK now! Thanks again I'll give it a whirl and let your know!

avatar image Khubur Jan 24 '19 at 12:20 AM

Technically, I don't know.

My intuition is there could be specific system calls requirements will be executed during build progress for Windows platform.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question