x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Low FPS when looking at specific object in editor

I'm encountering this problem for the first time, did not have it before.

I have imported this house: https://www.unrealengine.com/marketplace/scl-house-01

and placed it in this landscape: https://www.unrealengine.com/marketplace/procedural-landscape-ecosystem

At first, when I imported the house into the landscape, I did not have any problem of low FPS in the editor. The problem started after I built the lighting. Now, if I'm looking at the house from outside, I have a low FPS, around 2. If I look in the other direction, without the house in the field of view, only trees and mountains, I have good FPS, around 90. I have a high end PC with Titan XP GPU, never had low FPS until now. When i'm inside the house, in some directions the FPS is ~ok, around 20, but in others it's slow around 5.

Not sure why I suddenly have this problem. If I have only the house in another level, the FPS is good, same for the landscape.

Product Version: UE 4.21
Tags:
more ▼

asked Jan 26 '19 at 09:07 PM in Rendering

avatar image

Hugues1965
48 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Found it. I turned off all assets, then turned them on one by one until i found the one that make my FPS sink. It was a few spotlights that were set to Stationery instead of Static. Changed them to Static and all is fine now, got 90 FPS everywhere I look now. Not sure if this behavior is normal though.

more ▼

answered Jan 28 '19 at 08:34 PM

avatar image

Hugues1965
48 2 5

avatar image Jacky Jan 28 '19 at 09:21 PM

It is normal if you hadnt built the lights yet. If it happened after build then probably there were more than 4 overlapping stationary lights and they were using dynamic shadows, which again can be normal depending on other elements in the level.

avatar image Hugues1965 Jan 29 '19 at 06:13 AM

Happened after I built the lights. And indeed they were stationery and overlapping. But they are still dynamic shadows and it seems to be fine now, shall i remove dynamic shadows too ?

avatar image Jacky Jan 29 '19 at 12:01 PM

If more than 4 are not overlapping anymore you dont need to disable dynamic shadows. If they had overlapped some objects would have been affected by multiple dynamic lights at the same time and that could have been problematic.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question