x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I use the TapJoy Plugin

I have enabled it in the editor.

Now I need to know how to call it from a Blueprint

Thanks

-Pat

Product Version: Not Selected
Tags:
more ▼

asked Aug 21 '14 at 02:02 PM in Using UE4

avatar image

Patrick Simmons
11 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

There are Blueprint Library Functions for showing/hiding the ad. Look for Show Ad Banner and Hide Ad Banner.

You will also need the default provider registered in your INI file.

 [Advertising]
 DefaultProviderName=IOSTapJoy
more ▼

answered Aug 21 '14 at 02:45 PM

avatar image

joeGraf STAFF
1.5k 35 12 69

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I added this code to the DefaultEngine.ini in my project (I am using Tappy Chicken for now), and when I start the game on my IOS Device, a message stating that iostapjoy failed to load because module IOSTapJoy could not be found.

I tried running GenerateProjectFiles.sh and re-built the game for iOS and the Engine for Mac and I don't think that IOSTapJoy is being complied.

Can you help?

TIA

-Pat

more ▼

answered Aug 22 '14 at 01:02 PM

avatar image

Patrick Simmons
11 1 2 2

avatar image joeGraf STAFF Aug 22 '14 at 01:12 PM

Did you enable the plugin in the editor? If it's not listed in your .uproject file, it won't get compiled in

avatar image Patrick Simmons Aug 24 '14 at 03:59 PM

I am still not able to get around the problem of the app not find the plugin

Here are the exact steps:

  1. Download install the engine and ios game projects

  2. Change DefaultProviderName to "IOSTapJoy" in Engine/Config/IOSEngine.ini

  3. Run the newly built engine

  4. Create project based on the blueprint puzzle game example

  5. Enable the plugin

  6. Modify DefaultEngine.ini, adding [Adverting] DefaultProvideName=IOSTapJoy

  7. Restart the engine

  8. Double check the the plugin is enabled

  9. Add blueprint logic to call the plugin 10 Compile the blueprint

  10. Launch the app on my ios device

Before the game starts the message "Plugin IOSTapjoy failed to load because module IOSTapJoy could not be found. Please ensure...

Do you see what I am doing wrong?

Note that I am using a Mac for all of this.

Thanks

-Pat

avatar image joeGraf STAFF Aug 25 '14 at 04:10 PM

Those are the steps that I did for my plugins, so I am at a loss as to why it's not working. I'll have QA take a look at it.

avatar image Patrick Simmons Aug 25 '14 at 07:43 PM

I will patently await your reply

-Pat

BTW, I am using version 4.4

avatar image jeffvoigt Dec 31 '14 at 07:22 PM

I was finally able to build from a windows machine using remoteBuildTool on a mac with enabling all of the same things you mentioned above. I even have a timer calling show top / hide / show bottom / hide with delays and NOTHING is showing up. I did all of the steps mentioned above as well..

I'm on 4.6 source w/a c++ project using remote build.

avatar image jeffvoigt Mar 02 '15 at 05:30 PM

FYI. We upgraded to 4.7 and the process is more more bug free. However, we still don't see anything: Updated the other ticket:

https://answers.unrealengine.com/questions/148809/build-failed-related-to-tapjoy-ad-plugin.html

avatar image kina9876 Apr 17 '15 at 07:11 AM

Hi jeff.

I'm also tired to setup third party. :)

I've seen those questions because I would like to use and setup a third party ads in UE4. Have you solved the problem? If you have some way to solve this problem, please tell me how to build and how to modified plugin.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question