x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Scale3D is (nearly) zero warning

Hi,

I'm currently working in UE4.17.2, so this issue might have been solved with updates but I couldn't find anything online. Basically, I have a bp class with a mesh component and by default the component's scale is (0,0,0), I scale it up to (1,1,1) with code sometime after its being instantiated. My problem here is that unreal clutters the log file with the following warning every time I create a new instance of it :

"LogPhysics: Warning: Initialising Body : Scale3D is (nearly) zero: "

Does anyone know if there's a way to mute that warning? And/or does anyone know why it is a warning?

Product Version: UE 4.17
Tags:
more ▼

asked Feb 02 '19 at 12:50 PM in Blueprint Scripting

avatar image

Gamji
8 4 5 11

avatar image ThompsonN13 Feb 02 '19 at 05:35 PM

i would guess thats the issue is that your trying to simulate physics on a object that has no mass. basically a object with scale 0 shouldnt exist. you could try giving it a very small scale or try toggling physics to off until you begin scaling the object up.

im basing this off of your error report and i have not actually tried to replicate so this is theoretical.

avatar image Gamji Feb 02 '19 at 05:56 PM

Thanks for the reply! Not using physics at all tho, but I do have a collision sphere so that might be why it's complaining about the scale. Yeah i'll try play around with the scale see if there's a threshold at which it doesn't send a warning.

avatar image ThompsonN13 Feb 02 '19 at 06:03 PM

hmmm i just tried to recreate the issue but i didnt get any warnings. whats your exact setup like?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Right, so I have two classes, in one I have a static mesh component, in the other a skeletal mesh component. By default both component were at a scale of 0.0001. I first put the static mesh's default scale to 0.01, which made the log I was getting disappear and I instead received a more details log telling which object it was coming from (in this case my class with the skeletal mesh). So I applied the same fix to that too.

"LogPhysics: Warning: Initialising Body : Scale3D is (nearly) zero: Component: '/Temp/Autosaves/Game/Maps/UEDPCDesert.Desert:PersistentLevel.BM_Unit_C_0.SkeletalMesh' Bone: 'BE_Butt_01' "

I'm guessing it struggled to display exactly where it was coming from when it came from both a static mesh and a skeletal one?

more ▼

answered Feb 06 '19 at 01:51 PM

avatar image

Gamji
8 4 5 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question