x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Steamvr: how to enable Vive hmd in standalone game?

I'd like some help working out how to enable the vive hmd to work in the standalone preview in ue4, My game starts and also packages correctly, however despite using the enable HMD blueprint node and the vr.bEnableStereo True command both in blueprint and as a console command, it has not done anything but show the player camera sitting on the floor and showing nothing in the vive hmd, start in vr in project settings is also already enabled.

Can somebody please help me to get the hmd to start working for my game, I dont know what else to try.

Product Version: UE 4.20
Tags:
more ▼

asked Feb 04 '19 at 12:57 AM in VR

avatar image

Aikirob
37 3 3 7

avatar image mrteuy Feb 04 '19 at 03:55 AM

I would check to see if its an issue with possessing the player character if all those others are correct. Typically, it's steamvr that I need to reset when it does this.

avatar image Aikirob Feb 04 '19 at 09:52 PM

that would probably be the case, I haven't changed those settings, could you please let me know what the settings need to be? the player is being possessed, but the hmd remains blank and isn't displaying anything when the game starts.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I have solved this issue 1. you must have start in vr enabled in project settings. 2. you have to have enable hmd node in your blueprint 3. the ue4 editor is bugged, it wont work when you press play as standalone in VR, you have to use packaged build.

more ▼

answered Feb 05 '19 at 12:22 AM

avatar image

Aikirob
37 3 3 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

To build on this in case it pops up on searches, I have found that's it was more of my misunderstanding of all the systems involved that caused my game not to start in VR. For VR, I've used 4.19, 4.20, and 4.21 and all have sufficiently worked with the start in vr option alone.

If you are having trouble in the editor, what it usually is for me is SteamVR. When an app opens that uses VR, SteamVR "latches" to it and if you try to open another program that needs it, the system can't tell which it needs to work with and usually doesn't work. It will stay like this until you close all apps using it, and restart SteamVR. I have to say with the most recent update, it isn't as bad on the restarting SteamVR portion, but I find that I have to usually restart it more frequently due to "compositor not found" issues.

more ▼

answered Feb 05 '19 at 12:39 AM

avatar image

mrteuy
146 2 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question