x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

textures have gone blurry

I upgraded to UE4.4 recently and just noticed that so many of my 2048x2048 textures that were created in Zbrush have gone all blurry. Some of my other textures are fine. Some that I created in Zbrush are fine. But most, around 40 of them, have gone all blurry and now my game looks terrible. Here is an image: https://dl.dropboxusercontent.com/u/7072449/frog_wtf.jpg

You can see in the game it's making the characters look terrible but yet that little table you can see in the corner is fine. There is no detail in any characters. I have the image opened in photoshop on the right and you can see that there is a lot of detail and opened in ue4 on the left, it is super blurry. I've tried rebuilding lights, reimporting the images in a lot of different formats...this must be something easy, some box I have unchecked or something? it's driving me crazy. Any help much appreciated.

Product Version: Not Selected
Tags:
more ▼

asked Aug 21 '14 at 09:41 PM in Using UE4

avatar image

treebykooba
36 7 9 11

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Go into the texture editor and make sure you have a proper MipMap Generation setting. It will be under the Level of Detail settings.

It looks like you have it set to FromTextureGroup, try none and see what happens.

alt text

Or you can go under the Texture settings, click the drop down, and change the Filter. Try nearest neighbor or default under that.

alt text

more ▼

answered Aug 24 '14 at 09:30 AM

avatar image

MrDoxies
102 7 10 18

avatar image Stephie-san Apr 06 '16 at 11:56 AM

Thanks for the answer!! Worked like a charm on my project :D

avatar image gruschi Sep 11 '16 at 10:37 AM

Wow, this happend to me when I migrated my project from 4.12 to 4.13. Thought it is a migration problem. This post saved me alot of time/work!

avatar image AntimonyFox Sep 14 '16 at 06:02 PM

This even helps with render targets when you need the pixels to be precise. Changing the filter to Nearest did the trick.

alt text

crisp.png (57.1 kB)
(comments are locked)
10|2000 characters needed characters left

Still doesn't work for me. I use extremely low resolution textures (32x32 in this instance), and there's always blurring. Completely impossible to turn off in UE, as far as I can tell. The texture preview becomes sharp with filtering set to "Nearest", but it combines a lot of pixels into single color blocks, and the result on the model is still extremely blurred.

more ▼

answered Jan 13 '18 at 04:53 PM

avatar image

Theon
6 1

avatar image MrDoxies Jan 13 '18 at 10:00 PM

Right click the texture in your content browser and Sprite Actions > Apply paper2D Texture Settings

Set Filter and MipMap settings as needed.alt text

sprite.png (672.2 kB)
avatar image Theon Jan 13 '18 at 10:20 PM

That helps a lot, but there's still some mipmap-blurring, and pixels are still combined into single color groupsalt text.

unrealtextures.png (40.7 kB)
avatar image MrDoxies Jan 13 '18 at 10:51 PM

Your compression settings are still set to default, it needs to be UserInterface2D

avatar image Theon Jan 13 '18 at 11:12 PM

Oh, that actually worked! Thanks! There is still a little bit of mipmapping going on, though.alt text

mipmapping.png (102.4 kB)
avatar image MrDoxies Jan 13 '18 at 11:15 PM

I'm not entirely sure what to do about that since I don't have a similar model to test on. Looks more like a shading issue on the model than MipMaps to me though.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question