x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Motion Controller Button Inputs Not Working in VR Template

Hi, I'm using a completely fresh VR Template Motion Controller map and it's tracking the position of my Vive controllers properly, but it isn't detecting any of the button inputs.

I know teleportation works because I made it activate on the mouse being clicked and it all worked correctly. However, absolutely none of the actual buttons respond when pressed.

Product Version: UE 4.21
Tags:
more ▼

asked Feb 05 '19 at 03:51 PM in VR

avatar image

Lepidora
1

avatar image mrteuy Feb 06 '19 at 01:01 AM

Are they mapped under input or in the blueprint?

avatar image SplicedImmersive Mar 02 '19 at 01:37 AM

Did you ever figure this out?

avatar image mrteuy Mar 26 '19 at 01:41 AM

Look under project settings / map, modes to see if a player controller is configured. If so, that may be consuming input.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

In new blueprints you have to enable player input.

Its an option in the Class Defaults (top bar on the event graph), under the input catagory. As standard it is set to disabled. If you have a single player, set 'auto receive input' to player 0, That should enable input.

alt text

input.jpg (29.3 kB)
more ▼

answered Feb 13 '19 at 08:55 AM

avatar image

BdeJong
42 6 15 19

avatar image discreetfire Mar 25 '19 at 10:24 PM

I'm having the same issue with Auto Receive Input set to "Player 0". All buttons are correctly mapped. All of my VR Maps that I've previously created and have tested for button input play are all not working as well. Lastly, when I launch Oculus game from my Oculus Library, like the Oculus First Contact primer game, the controllers DO work. I am thinking that Unreal Engine install has somehow correpted itself. I'm running the current 4.21.2 Hotswap version.

avatar image discreetfire Mar 26 '19 at 01:17 PM

I'm having the same issue as above poster, my motion controllers are movement tracking however all inputs on controllers are inactive.

My configuration is as follows: For simplicity of debugging, I'm using the VR template with Auto Receive Input set to "Player 0". All buttons are correctly mapped. Furthering my pain is the fact that all of my VR Maps that I've previously created and have tested for correct button input play are all now suddenly not working. Projects that have I have developed previously with multiple levels and VR capabilities, are all suffering the same fate, no input control from the controller.

Lastly, when I launch any games from from my Oculus Library, like the Oculus First Contact primer game, the controllers DO work. I am thinking that the Unreal Engine install has somehow corrupted itself. I'm running the current 4.21.2 hot swap version. Help is most appreciated in this matter and Thank You!

avatar image mrteuy Mar 26 '19 at 01:41 AM

Look under project settings / map, modes to see if a player controller is configured. If so, that may be consuming input.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question