x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android Google VR: NoSuchFieldError

Hello, I am using UE4 4.21.2 built from the latest release.

I am getting the same error as in

https://issues.unrealengine.com/issue/UE-65983

which supposedly has been fixed.

This error causes the Android app to crash on startup:

java.lang.NoSuchFieldError: com.google.vr.cardboard.R$id.ui_settings_button_holder

I have attached a dump of the full error.

Is this a bug or am I doing something wrong?

-Max

[1]: /storage/temp/267789-dump.txt

Product Version: UE 4.21
Tags:
dump.txt (2.0 kB)
more ▼

asked Feb 07 '19 at 01:19 PM in Packaging & Deployment

avatar image

OldRealms
6 1 1

avatar image Fieol Apr 27 '19 at 01:02 AM

Hi, I got the same error

 04-27 06:28:15.454 19383 19383 E AndroidRuntime: java.lang.NoSuchFieldError: No static field ui_settings_button_holder of type I in class Lcom/google/vr/cardboard/R$id; or its superclasses (declaration of 'com.google.vr.cardboard.R$id' appears in /data/app/com.FieolLabs.Yaniv360-lYR0AAN11Jzr8oJuexIuJg==/base.apk)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello, I'm experiencing this same issue, Have you found any solution?

more ▼

answered Mar 17 '19 at 12:18 AM

avatar image

dranzyAdix
1 1 1

avatar image OldRealms Apr 27 '19 at 09:13 PM

I found a solution. Its called Unity. ;)

avatar image Fieol Apr 29 '19 at 08:34 AM

Unity multiplayer sucks though :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question