x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Icon Settings and proper sizing not showing up in taskbar correctly

When I package our projects I used to get the icon we use for the .exe in explorer showing correctly along with when you run it showing correctly on the taskbar and the window itself. Now since we have updated to UE 4.21 only our .exe in explorer shows up correctly and the default UE logo shows for the window of the exe and in the taskbar. I have looked all over answerhub and google to people having similar issues and finding fixes that "worked" for them. I have tried all of these.

I have formatted our .ico in so many different ways using online tools to other specific icon editing tools. I can get our icon showing on the taskbar and window only after I build and package the exe. Then edit inside of Visual Studio. Basically over writing the default UE icons showing up.

I will include some screenshots with what I have seen and what I have done and some of my settings.

alt text This is showing the icon no problem in explorer for the main EXE

alt text But with some digging discover that the actual exe that is run is inside binaries which has the wrong logo.

If you inspect the exe in visual studio and actually find the icon folder you'll see two icon files. One is usually named 101 and the other is 123.

alt text So If I run 101 I see my custom Icon with the identical sizing that UE default icon uses.

alt text and If I open up the 123 icon I see the default UE icon with all the same sizing.

If I actually rename 101 to 123 and 123 to 1234 or something and save. I am able to get the correct Icons showing in the taskbar and window when the exe is run.

But that doesn't seem right to have to do that every time.

I don't really know where to go from here. I have also my icon correctly set in project settings and it shows up in the correct folder structure if you are wondering.

alt text

IE [projectname]/Build/Windows/Application.ico

Thanks for any help!

Product Version: UE 4.21
Tags:
capture1.png (43.0 kB)
capture2.png (37.9 kB)
capture3.png (48.6 kB)
capture4.png (56.5 kB)
capture5.png (58.7 kB)
more ▼

asked Feb 07 '19 at 11:11 PM in Packaging & Deployment

avatar image

NathanNaz
6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question