x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to bake proper shadows.

Greetings. I'm trying to learn unreal engine for the last week and i have a problem with my shadows.

I am trying to bake them but for some reason they look very bad. I tried with my light source as static or stationary but both look bad. Using dynamic shadows with movable light source looks good, I have a proper lighmap uv setup and no overlapping uvs. My scene is just a terrain, a house and one light source for now.

First screen is using static, second stationary and last one is my lightmap settings of the model. Thanks for your help in advance!

alt text alt text alt text

Product Version: UE 4.21
Tags:
more ▼

asked Feb 09 '19 at 06:30 AM in Rendering

avatar image

los_re
3 1 1

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey los_re,

Your UVs are being generated by UE4 itself and you Min Lightmap Resolution is still set to 64. Try setting that at 512 as well and apply it with the build button. This will get you way more accurate padding for your lightmap UVs.

more ▼

answered Feb 09 '19 at 11:46 AM

avatar image

WouterWeynants
21 1 1

(comments are locked)
10|2000 characters needed characters left

I pushed the resolution to 1024 and tried again. Things are much better, but still a bit off though. Note that these screens are with production (highest) detail shadows. Do you think the problem is just limited uv space? UVs in second channel made by me with better density will have better results maybe?

Btw what is the difference between min lightmap resolution and light map resolution? Should i put the resolution that i want in both fields? Thanks again! alt text alt text

more ▼

answered Feb 09 '19 at 01:36 PM

avatar image

los_re
3 1 1

avatar image WouterWeynants Feb 09 '19 at 01:50 PM

Min Lightmap Resolution is the resolution used during the building of the UV Lightmap

Light Map Resolution is the default lightmap resolution, this can be overridden on the StaticMeshActor in the details panel:

alt text

It is best to keep the Min Lightmap Resolution as close to your actual Light Map Resolution to get accurate padding between UV islands.

Looking at your mesh complexity, you might be better off splitting it in 3-4 parts and give each part a 512 or 1024 resolution. House_Roof, House_Walls, House_Floor, etc.

lightmapuv.png (6.1 kB)
avatar image los_re Feb 09 '19 at 03:36 PM

Alright, i think i understand the problem. Do i do the splitting in my modeling application and making my own uvs in new channel or is there an option i can use inside unreal in the auto generating uvs?

My problem is that my mesh is already split (roof, walls, etc) but when i import it in unreal the lightmaps uvs get combined. Do i have to untick the "Combine Meshes" in the import in order to use multiple lightmaps uvs? I hope the above makes sense to you. Unfortunately english is not my native language. Thanks again.

avatar image WouterWeynants Feb 09 '19 at 03:50 PM

Yep, unticking Combine Meshes can do the trick.

Splitting up the mesh is done in your modeling application indeed.

UVs should automatically be taken care of if you set each of your imported meshes up as you did in the above screenshots.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question