x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How do you add dependencies to Source "engine" module

I can't seem to add a new module I created to the runtime/engine module's build.cs dependencies. So to make sure I'm doing it properly, how do you add a new module to a source build, and how would you add that module as a dependency for the runtime/engine module? Thanks

Product Version: UE Github Master branch
Tags:
more ▼

asked Feb 09 '19 at 11:55 PM in C++ Programming

avatar image

iSpam
3 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The exact same way, all modules work the same, projects and plugins are just different way of manage and distributing them. you my try to rebuild the enigne.

more ▼

answered Feb 10 '19 at 03:05 AM

avatar image

Shadowriver
36.6k 931 169 1111

avatar image iSpam Feb 10 '19 at 04:01 AM

That's what I figured. So I added my module to the runtime/engine build.cs private and public dependency ranges, even tried the pathinclude ranges then clean and rebuild after deleting the intermediate folders, but I would still get linker errors to my module classes

avatar image iSpam Feb 11 '19 at 02:25 AM

Once again tried adding the module. I added my module to the private and public include paths in engine.build.cs and it seems to recognize my classes in the includes. Yet on compile it states "Unrecognized Type", even though intellisense is acknowledging the class.

avatar image iSpam Feb 11 '19 at 04:47 PM

When you add a module to a regular project, you have to add it to the .uproject. Is there something similar for the source engine? I went into my project's properties, looked at the "Include Search Path" for "All Configurations", and there my module is, exactly how every other module with generated files is. So I have to be missing something on set up. I've looked around and found no info, so the only thing I've down is copied my runtime module into the runtime folder, and my editor module into the editor folder. Is there another step?

avatar image jvp2001 Apr 14 '19 at 10:05 AM

Have you fixed your problem or do you need more help? If so, just clarifying, did you create/add your runtime module to the runtime directory in he engine? Also, can you expand on, or show a screen shot of the Unrecognized Type error? Thank you.

avatar image iSpam Apr 14 '19 at 01:34 PM

I never did manage to fix it, so I just migrated my files into existing engine modules. I did put runtime modules into the runtime directory and editor modules into the editor directory. As for the rest, I don't have access to my project and won't for a month or so. Once I do I'll set up my project once more and share it if you like. Thanks for helping

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question