x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help! School Project. Only one actor in class responds to player

So I am making this game where you can swap bodies, and I have these zombie bodies laying around that the player can possess if the player has enough energy (well, the player teleports to their position and drops a body behind). Anyway, for some reason I can always only possess the last Zombie body (ZombieSpawner) that was dropped in the editor. For example is there is Z, Z0, Z1, Z2, I can only possess Z2. The code I have here is for the bodies and is called ZombieSpawner. Any help is appreciated. I have to fix this asap.

ZombieSpawner BP https://blueprintue.com/blueprint/fzsn2ppn/

Product Version: UE 4.21
Tags:
more ▼

asked Feb 10 '19 at 11:16 AM in Blueprint Scripting

avatar image

xGameSlave
11 3 6

avatar image Trefexx Feb 10 '19 at 11:45 AM

Why are you setting "Can Swap" so much?

Is your energy level check being skipped on purpose? The node isn't plugged in properly.

You should put breakpoints and see where the flow goes for setting CanSwap. Press f9 on the nodes you want to break at, and then hit play and use the skip/into buttons at the top.

avatar image ThompsonN13 Feb 10 '19 at 03:10 PM

it sounds to me like a input consumption issue. try selecting your input action event, then in the details panel uncheck the consume input checkbox.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question