x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Access None in Level Blueprint on packaged build, but works in Editor

Hello Community!

I'm having a severe issue with some variables being None on packaged builds (Windows 64-bit to be exact) and being valid in Editor. In the Level Blueprint, I did the 'IsValid' checks on them and still no luck... Ever since I upgraded to 4.21 it's been this way. I'm not sure if this is a potential bug, but it's been happening. If anyone has solved this issue before, please let me know :(.

NOTE The only ones that are doing this are the UserWidget objects.. My MainMenu Widget does this as well with the exact same 'IsValid' setup on packaged builds since 4.21 . I've even tried to use a widget that I know works in game as well... but for some reason in Level Blueprint, this just does not work.

UPDATE I decided to decouple the Cutscene Skip User Widget to be communicated with the Pawn in the scene. This actually fixes the issue, but doesn't explain why this is happening within the Level Blueprint to be broken?

Issue

 [2019.02.10-12.02.22:549][ 66]LogScript: Warning: Accessed None trying to read property SkipUI
     Introduction_C /Game/FirstPersonCPP/Levels/Introduction/Introduction.Introduction:PersistentLevel.Introduction_C_3
     Function /Game/FirstPersonCPP/Levels/Introduction/Introduction.Introduction_C:ExecuteUbergraph_Introduction:0124


Product Version: UE 4.21
Tags:
issue.png (136.0 kB)
more ▼

asked Feb 10 '19 at 12:03 PM in Packaging & Deployment

avatar image

CHADALAK1
128 25 24 30

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Sounds like this could be an issue with initialization order. This is not guaranteed to be identical in editor and packaged build. Do you do any work in begin play nodes? Could it be the case that you are doing something before the pawn has been initialized and that is why it is not valid at the time you are trying to create the widget?

If this is the case try to reorder your code so the beginplay logic doesn't depend on specific actors being initalized or make it wait until they are.

more ▼

answered Feb 11 '19 at 10:43 AM

avatar image

jevk
26 2 2

avatar image CHADALAK1 Feb 11 '19 at 09:56 PM

jevk,

I have an 'Introduction Pawn' in the scene right now by default. I also have the player controller possessing the pawn before creating the Widget as well.

Issue

issue2.png (261.0 kB)
avatar image CHADALAK1 Feb 11 '19 at 10:15 PM

I actually solved the problem @jevk ! Thanks to you, I got a brain blast on what could be happening.

Soo from the above comment I posted, the actor that contains another widget blueprint is being casted to bind an event. Little did I know this was the crippling issue on the rest of the callstack in Begin Play. Strange enough, Level Blueprint doesn't like binding events to a component from an existing actor? So I created delegates within the actors that contain the widget and binded a custom event within the actor to call the delegate to Level Blueprint. That there worked 100%. ... If anyone wants details/visuals on how I did this, I can post the image in the comments

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question