x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Text passed into Widget from a struct disappear

Hey guy! so i have the struct variable in my widget and i checked Instance Editable and Expose on Spawn and i used print string before connecting it to Create Widget to see it is really not empty, then in the widget i used Bind to Text to show it on screen, and nothing shows, i tried deliver only the text and not the whole struct, tried to make the Text Box Public and Set the Text in it from outside after creating the widget, tried to make custom event that i called after Create Widget to set the Struct or Text, then it wasn't empty in the widget when i used Print Screen, but when i tried to Bind it or set the text to it, it shows nothing, even thru another text variable in the widget, I'm all out of ideas what to do and how to get around it, can someone please explain to me what is the problem? P.S I've tried each solution separately, the photos are only for illustration of the problem.

alt text alt text

Product Version: UE 4.20
Tags:
more ▼

asked Feb 10 '19 at 05:21 PM in Using UE4

avatar image

VR class
3 1 2 4

avatar image VR class Feb 11 '19 at 03:14 PM

Now i got a similar problem with a float value in an Actor. alt text you can clearly see the Default value of Strength is set to 20.0 but when i print it out to screen it shows 0.0. am i doing something wrong? i must be missing something. please help!

unrealproblem3.png (436.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question