x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Imported FBX has no size

no size

I'm trying to import an FBX that was created in Blender 2.79b. Every time I import, I get a static mesh with no size. I'm not doing anything fancy with the settings or scaling.

Thanks!

Product Version: UE 4.21
Tags:
phone.png (166.8 kB)
export.png (24.0 kB)
import.png (64.4 kB)
no-size.png (78.1 kB)
more ▼

asked Feb 10 '19 at 08:58 PM in Using UE4

avatar image

edahle72
1 1 1

avatar image darkok25 Feb 11 '19 at 12:09 AM

why not upload fbx online so we can check what's wrong

avatar image edahle72 Feb 11 '19 at 12:13 AM
nokia0.zip (1.4 MB)
avatar image edahle72 Feb 11 '19 at 12:14 AM
avatar image darkok25 Feb 11 '19 at 12:36 AM

I got no problem uploading it to 4.19, try this version i exported from OBJ to FBX with blender here

alt text

12.png (119.5 kB)
avatar image edahle72 Feb 11 '19 at 01:10 AM

Having trouble accessing that link - it looks like a Gmail link?

avatar image darkok25 Feb 11 '19 at 01:14 AM
phone1.zip (989.0 kB)
avatar image edahle72 Feb 11 '19 at 02:49 AM

Same issue for me using your file! It has no size when I import it. That's so strange....I am using UE 4.21. alt text

phone1.png (164.1 kB)
avatar image edahle72 Feb 11 '19 at 02:51 AM

It also shows way more triangles and vertices, UV channels, materials, etc. on your screenshot.

avatar image edahle72 Feb 11 '19 at 12:52 PM

Is there anyone who can successfully import either model linked above (phone1 or nokia0) into 4.21? I've tried a bunch of different import settings, and although I was able to match the vertex/triangle count from darkok25's screenshot, nothing seems to work. The approximate size is always 0x0x0 and Collision Prims is always 0.

avatar image darkok25 Feb 11 '19 at 01:52 PM

I just tried it on 4.20 and it still worked, try to import it in lower versions like 4.19 or 4.20 or you can reset 4.21 to default settings

avatar image edahle72 Feb 11 '19 at 02:26 PM

I'll have to download 4.20 to try that. My project is built in 4.21 though, so I'd prefer to keep it that way.

avatar image edahle72 Feb 12 '19 at 12:56 AM

What do you mean "reset 4.21 to default settings" - are you talking about the import settings? I've tried using the default import settings with no luck.

avatar image SenseiHaketon Feb 11 '19 at 02:24 PM

Show us your import settings. It worked for me as well.

avatar image edahle72 Feb 11 '19 at 02:27 PM

There's an attachment on the original post called "import.png". It worked for you in which version of the engine?

avatar image edahle72 Feb 12 '19 at 12:56 AM

Which version of the engine are you using?

avatar image edahle72 Feb 12 '19 at 07:33 PM

Is anyone able to provide guidance for 4.21 ? Like the darkok25 and SenseiHaketon, I was able to import the FBX into 4.20 with default settings fine. Importing into 4.21 with default settings or any combination doesn't work.

avatar image darkok25 6 days ago

I even tried with 4.21 and it still worked. So it's 100% something with your project, try making new 4.21 project for testing. here is model i exported from 3dsmax 2017 who knows maybe it will work

phonetest.zip (990.5 kB)
avatar image edahle72 6 days ago

Wow, darkok25, I imported the model you just posted, same default import settings witn 4.21 and it worked just fine! So, you brought a model into 3Dsmax2017, exported it, and that's it? I had made a new 4.21 project previously, and used the previous model and it didn't work, but this one totally did. So strange.

avatar image darkok25 6 days ago

yeah, just that, i already had problems with models that simple import/export from 3dsmax2017 solved, i guess it's better software than blender.

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question