x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to Improve CCD For Small Objects?

I am developing a physics based pinball game and I am trying to correctly set the physics simulation.
The problem is demonstrated in this video.

The simulation is fine when the ball collides with the flipper most of the time; but, at the tips of the flipper, as it is thinner, it does not act as desired.

I have tried to solve this issue according to this question but I could not make it work for myself.

The flipper is a static mesh with mobility marked as Movable. Flipper in its Blueprint

The flipper's collision complexity is Use Complex Collision As Simple Flipper Collision Settings

The ball is also a static mesh and has its mobility marked as Movable in its blueprint. It also has sphere simplified collision. CCD is checked. Ball Settings

I use the default Engine - Physics settings in Project Settings. Physics Settings

Finally, this is the size comparison of both static meshes. Size Comparison

How should I approach this problem? I have looked at some questions and posts as I have mentioned before but I couldn't solve the issue. If I need to modify the PhysX, UE4 uses, how do I do that?

Product Version: UE 4.21
Tags:
screenshot-33.png (273.3 kB)
screenshot-34.png (230.4 kB)
screenshot-37.png (424.4 kB)
screenshot-36.png (37.9 kB)
screenshot-38.png (516.4 kB)
more ▼

asked Feb 11 '19 at 03:02 PM in Using UE4

avatar image

kenanmarasli
1

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

The solution I have found is to generate collision instead of using the Use Complex Collision As Simple. The physics simulation works as desired now.

Although the mesh itself is convex and rather simple - It has eight vertices -, the collision behavior differs between mesh complex and UE4 generated simple collision when collided with sphere simplified collision. It may be the case for other collisions as well but I cannot say without testing and/or seeing the source code.

Plus, I have forked the UE4 repo and I am currently learning to create my custom UE4 development environment. For more information related to this, visit this unreal engine forum.

more ▼

answered Feb 13 '19 at 06:29 AM

avatar image

kenanmarasli
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question