x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cannot build ShaderCompileWorker

After building the latest git release branch on Fedora 29 I got the following error when running UE4Editor:

 Couldn't launch .../UnrealEngine/Engine/Binaries/Linux/ShaderCompileWorker! Make sure you build ShaderCompileWorker.

Then I manually tried to build ShaderCompileWorker like this:

 ./Engine/Build/BatchFiles/Linux/Build.sh ShaderCompileWorker Linux Development -verbose

and received the following linker errors:

 Performing 6 actions (10 in parallel)
 [1/6] Link (ld) libUnrealHeaderTool-BuildSettings.so
 .../UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/bin/x86_64-unknown-linux-gnu-ld: cannot find crti.o: No such file or directory
 .../UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/bin/x86_64-unknown-linux-gnu-ld: cannot find crtbeginS.o: No such file or directory
 clang++: error: linker command failed with exit code 1 (use -v to see invocation)
 ERROR: UBT ERROR: Failed to produce item: .../UnrealEngine/Engine/Binaries/Linux/libUnrealHeaderTool-BuildSettings.so
 

I located the missing objects in

 /usr/lib64/crti.o
 /usr/lib/gcc/x86_64-redhat-linux/8/crtbeginS.o

added these folders to LIBRARY_PATH, but the build still results in the same error.

 export LIBRARY_PATH=/usr/lib64:/usr/lib/gcc/x86_64-redhat-linux/8/

Any help would be appreciated.

-Gabor

Product Version: UE 4.21
Tags:
more ▼

asked Feb 11 '19 at 11:10 AM in Linux

avatar image

gabor.papp
11 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Is the toolchain complete? The file should be located at Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/usr/lib64/crti.o

Please check that you have it there, and if you don't delete the toolchain and run Engine/Build/BatchFiles/Linux/SetupToolchain.sh again.

more ▼

answered Feb 11 '19 at 02:11 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image gabor.papp Feb 11 '19 at 02:32 PM

Thank you. I'm not sure while the toolchain was not complete first, but this fixed it.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question