x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

=== Critical error: === Failed to compile default material /Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial!

Hi, I have been having this error. This occurs when i try to package my project to linux and with source build. I could build with empty project and engine 4.20

 UATHelper: Packaging (Linux):   LogMaterial: Display: Missing cached shader map for material WorldGridMaterial, compiling. Is special engine material.
 UATHelper: Packaging (Linux):   LogShaderCompilers: Warning: 0 Shader compiler errors compiling WorldGridMaterial for platform GLSL_150:
 PackagingResults: Warning: 0 Shader compiler errors compiling WorldGridMaterial for platform GLSL_150:


 UATHelper: Packaging (Linux):   LogWindows: Error: begin: stack for UAT
 UATHelper: Packaging (Linux):   LogWindows: Error: === Critical error: ===
 UATHelper: Packaging (Linux):   LogWindows: Error:
 UATHelper: Packaging (Linux):   LogWindows: Error: Fatal error: [File:C:\Program Files\Epic Games\UnrealEngine-4.20\Engine\Source\Runtime\Engine\Private\ShaderCompiler\ShaderCompiler.cpp] [Line: 2031]
 UATHelper: Packaging (Linux):   LogWindows: Error: Failed to compile default material /Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial!



 PackagingResults: Error: === Critical error: ===
 UATHelper: Packaging (Linux):   LogWindows: Error: [Callstack] 0x00007ff850ba73d7 UE4Editor-Engine.dll!FShaderCompilingManager::FinishCompilation() [c:\program files\epic games\unrealengine-4.20\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:2496]
 UATHelper: Packaging (Linux):   LogWindows: Error: [Callstack] 0x00007ff85079da82 UE4Editor-Engine.dll!FMaterialShaderMap::Compile() [c:\program files\epic games\unrealengine-4.20\engine\source\runtime\engine\private\materials\materialshader.cpp:1594]
Product Version: UE Github Master branch
Tags:
more ▼

asked Feb 12 '19 at 04:31 PM in Linux

avatar image

FinalZer0
121 2 7 12

avatar image LNaej Feb 12 '19 at 08:31 PM

I used to have this error on an old project and another version. Try to look for assets in your game using this default material which is Editor only. Try also to exclude every folder which is not supposed to be packaged from packaging in your Packaging settings.

A good way to see if one of your assets you are packaging is referencing this Material, is to right-click on this WorldGridMaterial in the content browser and "Find References". It should show you every asset referencing this WorldGridMaterial. Do not forget to enable "Show Engine content" and stuff like that in the content browser (can't remember where this Material is).

avatar image FinalZer0 Feb 18 '19 at 11:12 AM

Thank you for answering! I copy-pasted my project to another location and cleared out content folder and then packaged. It gave same error, so it does not depend on what material I use in my project. Also tried to make empty project and added a map, where is only one cube with WorldGridMaterial. This project was built with UE4.20 (Not source build) and build was successful. There is some problem with my engine built from source.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Please go to your project properties, Platforms -> Linux and disable GL3 there. For whatever reason there's an issue compiling default material in your engine installation for GL3. This RHI has been long deprecated anyway, so by not supporting it you will only save yourself more trouble.

(The compilation of the default material shouldn't fail nevertheless).

more ▼

answered Feb 18 '19 at 02:08 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image LNaej Feb 18 '19 at 02:36 PM

Thanks RCL! A quick question though: in 4.17 there is the same bug, even with just DX11 activated, do you know if there is a way to fix the problem in the 4.17 version?

avatar image FinalZer0 Feb 19 '19 at 01:37 PM

Thank you! It worked, and DefaultMat didn't fail. It compiled really slow tho...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question