x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird behaviour after spawning/attaching actor to Skeletal mesh socket.

Hi guys, I know this may sound like a really noob question, but I think it could be networking related in which I don't have such big experience yet.

I have two players connected to each other over network. Server and Client. An item lays on the ground which upon interacted is spawned in actors ThirdPerson mesh under GripPoint. What happens next is that well it is bit off, it appears on his knee to be honest but that is not the most important case. What really bugs me is that somehow, if Server picks up an item, he starts to move really weird, almost like teleporting, or lagging really. Client sees this behaviour. When client picks up an item, server cannot see him picking it up and sees his movement as normal, but on Clients window he is teleporting the same way Server did.

My question is, why is this weird teleporting/rubber banding behaviour comes from, it only happens after spawning and attaching the item to Skeleton Mesh component. In terms of one not seeing the other picking up the item I guess its purely replication issue, but the most important one is the weird movement. If you wish I could post a video or a gif here with this movement as well as Blueprints of what I am doing.

Product Version: UE 4.20
Tags:
more ▼

asked Feb 12 '19 at 10:13 PM in Blueprint Scripting

avatar image

Sh0ck1ngPh3n0m
6 2 1 3

avatar image Sh0ck1ngPh3n0m Feb 13 '19 at 11:27 AM

.

I am posting the part of my Blueprint which set the item transform to the Player's Third Person mesh and GunSocket

What is really interesting, the teleporting disappears after changing Transform Space. If the RTS World is chosen, the item is transform is set to somewhere in the world and not the GunSocket, if RTS Actor is chosen, the teleporting/rubber banding issue occurs and the item is on knee level instead of being in GunSocket. If RTS Parent Bone Space is chosen, the issue occurs again but this time item is closer to the hand. If RTS Component is chosen, the issue disappears, but the item is in front of character so has quite big offset, and during running animation it could even change its location to be behind the Player completely.

screenshot-1.png (112.7 kB)
avatar image Sh0ck1ngPh3n0m Feb 13 '19 at 11:41 AM

.

I have also noticed that according to previous screenshot in comments, when the RTS was set to Component, I had all of the settings in AttachToComponent set to Keep Relative, but after I changed it to Snap to Target, which solved the issue with item appearing in wrong place the teleporting/rubber banding issue appeared again, and then when I tried to play with Transform Space of Socket Transform again, none of the Transform Spaces worked.

screenshot-2.png (70.5 kB)
screenshot-2.png (70.5 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Problem solved. Turns out my item had Collision turned to BlockAllDynamic. Which I believe during movement collided with the Player's mesh pushing it which looked like teleporting/rubber banding. With these collision settings, everything works fine and for all of you having same issue, my settings for Socket Transform Space are RTS World and for Attach Component are Snap to Target in Location and Rotation but Keep World in Scale Rule.

Have a good day UE4 community!

Collision settings

screenshot-3.png (34.0 kB)
more ▼

answered Feb 13 '19 at 11:54 AM

avatar image

Sh0ck1ngPh3n0m
6 2 1 3

avatar image Panquequinhas 5 days ago

None of the default types seem to work. This config worked perfectly, thank you!

avatar image Sh0ck1ngPh3n0m 5 days ago

Glad I could help :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question