x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

While in 3rd person play mode, the camera switches to first person in a specific area and some places have invisible barriers on them

I'm very new to UE4 so sorry if this is a stupid thing that i'm missing, but I just built a new area for a map iv'e been working on. When I fly around in the map it works fine, I can place stuff and look around easily. But when I try and go into play mode, the game switches to a strange 1st person mode and there are invisible barriers everywhere, but when I go into a different area that I built a little while ago everything works fine and as it should. I have a video if this doesn't make to much sense.

I can really use some help so thanks in advance to anyone who helps!

https://www.youtube.com/watch?v=S2M58_92H30&feature=youtu.be

Product Version: UE 4.21
Tags:
more ▼

asked Feb 13 '19 at 02:37 PM in Using UE4

avatar image

SargentSucc
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Looks like the problem is your meshes have big collision shapes. When the camera collapses with those collision shapes, the camera gets closer to its origin. In the editor, there's "Show" menu on the top left corner of the viewport. You can tick "Collision" and see what's blocking your character (or Alt+C to toggle the visibility of collisions). If the problem is about collisions, you can change them in the static mesh editor.

more ▼

answered Feb 13 '19 at 03:12 PM

avatar image

Core21.
70 2 3 7

avatar image SargentSucc Feb 13 '19 at 04:45 PM

Thanks for the answer but when I turn on the setting to see collisions i'm pretty sure it says that everything is fine in that regard. alt text

collision.png (1.6 MB)
avatar image Core21. Feb 17 '19 at 08:57 AM

Sorry for the late response, but I don’t know what causes that problem. It looks like the camera collides with something and the spring arm component makes the camera closer to its origin.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question