x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

blueprint question .

I figured it was about time to jump in and learn blueprints, I started by creating 2 projects one being the side scroller (blueprints only) and the other a blank project, then I recreated the side scroller BP's in my blank project to learn how to make them and how they work with each other but when I assign my camera BP to the "player camera class" of my controller BP and hit play all I get is a black screen, if I don't assign my camera BP and hit play it works using the default camera. there are 4 differences between the side scroller and my game.

  1. I used a different mesh, Its a sphere with 2 bones (I tried putting my sphere into the side scroller and it worked fine, so its not that).

  2. in my player BP I left out the jump function (because I don't need/want it).

  3. when I recreated the level BP there is a "delay" node witch says "target is actor" in the side scroller game but when I tried to make the "delay" node in my game it says "target is self".

  4. when I recreated my camera BP there is a "get actor location" node, it says "target is self" but in the side scroller the node says "target is actor".

other then those 4 things all settings and properties in my game are exactly the same as the side scrollers, I did try changing the nodes in the side scroller BP's to the same as the ones I had in my game and it still worked fine so I have no idea why my camera doesn't work.

any suggestions on what i've missed or done wrong?

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '14 at 04:15 AM in Everything Else

avatar image

ue4-archive ♦♦ STAFF
50k 3669 1999 9123

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

problem solved, turns out I didn't tick the return value in the return node for "update kismet camera" in my camera BP.

more ▼

answered Mar 11 '14 at 04:15 AM

avatar image

ue4-archive ♦♦ STAFF
50k 3669 1999 9123

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question