x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Object black after rebuilding lights (change light map resolution doesn't help)

My objects turned black after rebuilding lights alt text

Then I found this answer to let me change light map resolution to 512: https://answers.unrealengine.com/questions/282222/why-does-my-object-turn-black-when-i-build-the-lig.html I changed and it made my object show right color again, but then UE4 need me to rebuild lighting again. After I rebuilt the lighting, everything rewind. How can I escape this loop?

Product Version: UE 4.19
Tags:
black.jpg (110.5 kB)
more ▼

asked Feb 17 '19 at 06:38 PM in Using UE4

avatar image

Jadejadej
3 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

When you change lighting setting of an object or just move it or... Unreal will change its lighting back to dynamic!! /this is why you see the "correct" lighting/ But if your lighting is set to Static/Stationary then you'll have to build your lights...

Usually when a mesh turns black it doesn't get any lighting information! ...I'm not sure if these are black! There is another error message which says that Unreal won't be able to visualize the correct results unless you raise this or turn off completely! ...could be that your lighting is ok just the problem exists with the streaming pool!

more ▼

answered Feb 17 '19 at 07:45 PM

avatar image

Makigirl
1.2k 3 4 8

avatar image Jadejadej Feb 17 '19 at 08:10 PM

you're right, they're not completely black. but nearly black.

Regarding the texture streaming pool error, I tried to built the lighting in a small area, and because the area was small, there was no that error. But still the meshes were nearly black after building

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question