x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google Play leaderboard opens, shows its loading then closes before leaderboard shows up.

I'm developing a mobile game, in the mobile game we have leaderboards. I have setup the application with google play. We have setup OAuth and that side of things and I have inserted the details into the project.

I have a scoreboard called GameNameLeaderboard. I can read scores from this leaderboard using this ID Mapping with no problem. (Tested in last build).

I followed the documentation to setup a leaderboard with UE4.

The google play side of things is published as it should be.

We are running an internal test through google play and I have the application on my device, a samsung s6. All previous googleplay interactions have worked on this phone.

When I click the leaderboard button it opens the google play UI for leaderboards, it loads for a couple seconds and then closes the screen. I'm using the built in blueprint node for this, passing the matching category/id.

I have tripple checked the leaderboard id matches that on the Play Console. It does! If anyone can help me work out how to show the leaderboard that would be great!

Edit:

Turning auto login on googleplay game services has fixed this, what I am concerned by is that it's meant to be logging into the application anyway and has been confirming itself as logged in and yet still it didnt work without me changing a user setting.

If this continues for a user I'm not sure thats good enough. :/

Product Version: UE 4.19
Tags:
more ▼

asked Feb 20 '19 at 01:09 PM in Everything Else

avatar image

BouncyBox
1 1

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question