x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE4 Freezes when ran with -DX12 arg on laptop running 2080 MaxQ without secondary screen

UE4 Freezes when ran with -DX12 arg on laptop running 2080 MaxQ without secondary screen. It works fine when I launch it on a secondary screen as primary/sole screen.

  • I'm running a RTX 2080 Max-Q Design on the Razer 15, with the 418.91 drivers.

  • with Win10 1809

  • I select the laptop screen as primary/sole screen (secondary unplugged)

  • I fire UE4editor.exe with the -dx12 arg

  • launching a blank new project on which I have enabled both the enabled Support Compute Skin Cache and Raytracing in the project settings

Then the editor freezes after a few seconds. No crash, no crash window, but totally frozen. The rest of the machine is fine. the editor freeze seems to happen faster when opening the raytracing dropdown menu. It systematically freezes once Pathtracing kicks in or when I fire a raytracing Cvar.

But when I run it on a secondary screen as primary / sole screen, everything seems to be in order.

  • I have tried a clean re-install of both the Nvidia drivers and UE4.22 p2

  • I have also tried to reset all settings to default in the Nvidia control panel's 3D settings.

  • I'm not using any fancy software or anti-virus (new system)

  • The GPU activity monitor shows that UE4editor.exe is running with the 2080 Max Q GPU (even when ran with laptopscreen as primary/sole screen)

any ideas or advice?

Cheers, Stef

Product Version: UE 4.22 Preview
Tags:
more ▼

asked Feb 20 '19 at 09:34 PM in Bug Reports

avatar image

Stéphane Bourez
18 1 3 6

avatar image Jeff A ♦♦ STAFF Feb 21 '19 at 06:15 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image Stéphane Bourez Feb 22 '19 at 10:28 AM

Thanks Jeff, I've reported the bug: Case # 00099889

avatar image Ayu889900 Apr 03 '19 at 04:59 AM

Same issue on my Aero15x 2070maxq GPU, I have to use secondary screen to run raytracing, did you fix that?

avatar image tahayaki Apr 03 '19 at 06:24 AM

Exact same issue with me on a laptop with 2070. I couldnt fix it completely, and epic unfortunately couldnt reproduce it, but when I download editor symbols for debugging, and also add -d3ddebug as an extra argument besides -dx12, it runs without problems on some projects, but some larger projects crash anyway. I first thought the issue was related to ray tracing but I dont have any problems with Ray Traced games or My own built ray traced projects, i also dont have any problems without dx12 enabled. I just hope they could reproduce the situation, since it doesnt crash I also cant send crash reports, it would be cool if you also submit a bug report so maybe they can reproduce it with you, I dont think its a difficult to solve problem.

avatar image Skalamanga Apr 03 '19 at 09:49 AM

Same here, including the release version of 4.22.

Laptop is a Razer Blade 15, with an RTX 2070 MaxQ.

It also happens when using a thunderbolt dock (Razer Core X) with a Quadro RTX6000 installed, and connected to a 4K monitor.

avatar image tahayaki Apr 03 '19 at 09:54 AM

It could be perfect if all of you guys submit it, so maybe they could reproduce with you guys, I had unfortunately no luck.

avatar image Skalamanga Apr 03 '19 at 10:14 AM

just sent a report with the above information

avatar image PfazFWC Apr 09 '19 at 03:09 PM

I'm having the same issue with a 2080 version of the Razer Blade

avatar image tahayaki Apr 09 '19 at 03:22 PM

have you sbmitted a bug report

avatar image PfazFWC Apr 09 '19 at 03:48 PM

I've just submitted one now, yes

avatar image tahayaki Apr 09 '19 at 04:15 PM

cool, hope they can reproduce it.

avatar image Stéphane Bourez Apr 09 '19 at 04:28 PM

yep that'd be great. Thanks guys. I've installed NVidia's Creative Drivers, hoping that they might help forcing the card to prevent the lousy integrated graphics to interfere. they didn't.

avatar image tahayaki Apr 09 '19 at 04:33 PM

I did the exact same thing hoping the same result, unfortunately, it was the same result on my end too.

avatar image tahayaki Apr 09 '19 at 04:34 PM

btw you can also try to enable the d3ddebug to see if it helps, it works on my pc but some large projects crash.

avatar image xaviprz Apr 10 '19 at 04:24 AM

'm having the same issue with a 2060 rtx MSI GS65

avatar image tahayaki Apr 10 '19 at 05:34 AM

looks like a lot of people have the same issue on laptops, I wonder if theres even someone who doesnt have any issues on any laptop with an rtx card. did you report it btw?

avatar image pjoe Apr 11 '19 at 10:38 AM

Same issue on MSI GS65 (2070-MaxQ).

I can even make it freeze in the project explorer, just by right clicking a project a couple of times :S

Running on secondary screen seems to work though - pretty weird bug.

4.21.2 also seems to work fine.

avatar image tahayaki Apr 11 '19 at 12:57 PM

exact same situation, try enabling editor symbols for debuging, even though some large projects crash, you can at least run some smaller projects on your main monitor.

avatar image PfazFWC Apr 12 '19 at 09:38 AM

There are new Nvidia Drivers that looked like they might have solved it for a moment, but sadly it doesn't look like they have :(

avatar image tahayaki Apr 12 '19 at 09:48 AM

yeah, unfortunately the same, its real sad, now with the new geforce update I can run raytrace on my girlfriends laptop with a 1060, but it doesnt run on my laptop with an rtx 2070 which costed me a fortune, and the only reason I bought that laptop was being able to run ue4 with ray tracing features. I really want to cry.

And also as I said before it runs perfect if I enable debuging symbols, whic is a clear sign that it is software related, the only problem with debuging symbols is that it makes larger projects crash, do you guys think that maybe we should submit a report to nvidia?

And also theres is still no issue we can track, because I think the bug cant be reproduced by epic team, I think it can really be easily solved if it could be reproduced, since enabling debugging symbols solves it, it cant be that hard. I think for some reason whatever you click makes the Intel card kick in, it works as lond as I dont click anything else than viewport,.

avatar image Piash Apr 13 '19 at 07:44 AM

I am using Asus strix scar with 2060 I am also facing the freeze issue Already posted a bug report

avatar image Martijn1995 May 07 '19 at 12:38 PM

I also have this problem on my new laptop with rtx 2080...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

7 answers: sort voted first

Ok, I finally found a workaround, which is not the best but at least it lets you to work on any project if you dont have a monitor around.

Normally if you disable intel card from device manager before opening ue4, the engine doesnt work, but if you open the project with the intel card enabled and as soon as engine starts you should minimize the engine without clicking anything, its important that you minimize it, otherwise the video card crashes, then after minimizing go to the device manager and disable the intel card, then the editor should work.

more ▼

answered Apr 14 '19 at 03:50 PM

avatar image

tahayaki
11 1 2

avatar image PfazFWC Apr 16 '19 at 08:25 AM

This seems to work for me as well, though I haven't had a chance to test for more then a few minutes. I guess it must be some kind of clash between the cards? It doesn't really explain why this doesn't work when I turn the Intel card off before even starting the editor :S

avatar image tahayaki Apr 16 '19 at 09:09 AM

Thats also a total mystery to me. I also think its a conflict between intel and nvidia cards, but its weird that in only happens in ue4. even when you package an ue4 project, it seems to work fine, and when enabling debugging symbols, intel card probably cant kick in. I tried to submit a bug report but unfortunately epic couldnt reproduce it. I actually dont think its difficult to fix if they could reproduce it, since just enabling d3ddebug fixes the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

exactly same issue on desktop with 2x2080ti asus strix oc, 1080ti, 980ti, i9 9900k, 64gb g skill qvl ram, samsung 970pro.. new hardware, msi meg godlike, new windows, 4 monitors, 3 on 980ti, 1 on 2080ti - and still UE forced 1080ti to use as primary until I edited that .ini to force it to use 2080ti - and then it begins freezing constantly...

EDIT: no luck with latest hotfix as well, exact same issues as on laptops

more ▼

answered Apr 25 '19 at 07:23 PM

avatar image

robob3ar
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

There's been a ue4.22.1 hotfix release, anyone tried it yet? Theres a couple of d3d12 bugfixes. https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1612034-4-22-1-hotfix-released

more ▼

answered Apr 26 '19 at 06:13 PM

avatar image

Skalamanga
1 1 1

avatar image tahayaki Apr 26 '19 at 06:15 PM

I tried, still doesnt work for me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I just got a new SCAN 3XS RTX 2070 laptop and exact same issue on 4.22.1. Works OK on 2nd monitor. UE4 doesn't support SLI yet, so perhaps this issue is related in some way ?

more ▼

answered May 07 '19 at 12:24 PM

avatar image

Xx_Globillum_xX
6 2 1

avatar image PfazFWC May 07 '19 at 02:09 PM

I've heard people mention that it works on a second monitor. I realise now that I've only tried this with screen mirroring (both the laptops built in screen and the second monitor displaying the same image) and then it is still prone to freezing.

When you use a second screen and it works OK, are you using that screen exclusively? Also what port are you using? A lot of the RTX laptops seem to have the same configuration. Mini Display port, HDMI and USB-C, but I'm pretty sure the USB-C is connected to the Intel chip

avatar image Xx_Globillum_xX May 07 '19 at 03:04 PM

I just drag the UE window on the 2nd screen before it freezes. and yes, in my case USB-C = Intel chip.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

.. I'm thinking maybe list what hardware you're using, it might be drivers or something specific, I just had severe houdini crashes, and it was due to a Nahimic sound driver that I got with the MSI board dvd
- I'm on a msi z390 meg godlike board, i9 9900k, two asus strix 2080ti, asus 980ti, and msi 1080ti .. 3 dell monitors

  • running logitech mx master 2s / logitech options app, corsair liquid cooling - corsair link software, Asus gpu tweakII app, "killer control center" networking app (yeah who comes up with the names)..

..latest nvidia, and hotfix - still freezes..

.. might be some driver or software we all use so maybe post as much info you can think of, so maybe we can come up with something

more ▼

answered May 08 '19 at 04:01 PM

avatar image

robob3ar
1 1 2

avatar image Ayu889900 May 09 '19 at 02:11 AM

Same houdini crash due to Nahimic sound, i9 8950hk, 2070 maxq, lastest nvidia game ready driver, UE4.22.1, other software same with yours is killer control center app. Still freeze when click some menu or params after opening UE4editor

avatar image robob3ar May 10 '19 at 04:23 PM

killer control center, did you try killing that?

avatar image Ayu889900 May 11 '19 at 06:16 AM

I kill everything with killer* in task manager, UE4 still freezes

avatar image Ayu889900 May 11 '19 at 06:19 AM

Anyway freezing will be fixed in 4.22.2, so just wait

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Looks like this is finally being treated as an issue! Projected fixed version is 4.22.2 but give it a vote anyway just to be sure ;)

https://issues.unrealengine.com/issue/UE-74075

more ▼

answered May 10 '19 at 03:04 PM

avatar image

PfazFWC
66 3 6 12

avatar image tahayaki May 10 '19 at 03:07 PM

woaw, cool so they managed to reproduce it huh?

avatar image Stéphane Bourez May 13 '19 at 08:39 AM

Brilliant. Excellent news.

avatar image PfazFWC May 22 '19 at 09:03 AM

It's listed as fixed in 4.22.2, I've not had a chance to test it yet.

Is our nightmare over?

bugfix.jpg (278.2 kB)
avatar image robob3ar May 22 '19 at 12:48 PM

damnit, got a freeze (I'm on desktop) only this time it still runs the cpu but says not responding anyway.. .. maybe I should try with a new project or something?

avatar image robob3ar May 22 '19 at 12:50 PM

nope, not fixed for me

avatar image Stéphane Bourez May 22 '19 at 04:30 PM

In your Nvidia Control Panel>Manage 3D Settings> have you set Global Settings and/or Program Settings (pick ue4 in the dropdown) to High-performance Nvidia Processor ?

avatar image robob3ar May 22 '19 at 07:25 PM

I've just set it now.. and nope, still freezing, damn, now if it can't be reproduced it I'm screwed right? one of the reasons I got the rtx is exactly for ue :/ .. latest (gaming) mobo and latest gpus and it's screwed because of it ..

avatar image robob3ar May 22 '19 at 04:52 PM

ok I've disabled threaded optimisation, texture filtering to high performance and works for a few minutes more, got a freeze upon pressing on houdini engine ..ok might be working.. further testing

... almost working and after 20 mins freezes on disabling all lights, OK, at least I can do something more.. still might be buggy

avatar image Stéphane Bourez May 22 '19 at 04:30 PM

I'm happy to say that the freeze has been fixed with 4.22.2 I can't reproduce it, I've tried a few times and the engine behaves perfectly now.

@PfazFWC Let me know if everything works on your side and I'll be happy to mark this as 'answered'

avatar image robob3ar May 30 '19 at 01:21 PM

Yup, still freezes, stays on a bit longer, but not really solved

avatar image Skalamanga May 30 '19 at 12:54 PM

Not fixed for me, it stays stable longer but still freezes after several minutes.

Please do not mark this as answered until tests prove this is categorically correct.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

it also works for me without any problems now with the new update

more ▼

answered May 22 '19 at 04:32 PM

avatar image

tahayaki
11 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question