x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera detaches itself when saving?

I have an empty scene, added an Empty Actor and a CineCamera Actor. When I 'Attach' the camera to the Actor, it detaches itself when I save the level. All is well until I save. What's going on? What am I doing wrong? Seems like I'm missing something fundamental here.

The back story is: I'd like to import an animated FBX camera from Maya, reposition and offset it in UE4. In Maya I would typically just 'group' it and adjust the group. The methodology in UE seems to be creating an empty actor, attaching to that and moving the actor. I've distilled this behavior down to what I described above and it behaves unexpectedly when I save. Feels like a bug, but I can't be up against a bug on day 1! The bug is me.

Thanks in advance!

Product Version: UE 4.21
Tags:
more ▼

asked Feb 22 '19 at 06:55 PM in Using UE4

avatar image

spmky
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Answering my own question here. I was creating the CineCamera Actor via the button in the Sequencer. This creates a camera with a lightning bolt icon. Assuming this has something to do with it's spawning property which would explain why it would not be attached on spawn unless explicitly set to. Adding a standard camera via the Content browser works as expected and does not detach after save.

To clarify, this is probably not a 'detach on save', rather a 'not attached on open'. Which is confusing since I only saved.

more ▼

answered Feb 22 '19 at 07:52 PM

avatar image

spmky
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question