x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"object has wrapping uvs" error on static mesh (converted from geometry)

I'm whiteboxing a level and converted some sections of geometry brushes to static meshes as the sheer amount of geometry was causing issues for the engine (brushes turning invisible, crashes, etc.). However, the auto generated UV's for the lightmaps are all mangled up and on building gives the error "object has wrapping UV's", afaik indicating that UV's are overlapping.

Is there any way to set up the UV's differently so the lightmap for the static mesh comes out the same as it would on the brush? Or any other solution to make it less mangled? (something other than using an external 3D program to manually set up the UV's and re-import into the project, as this would drag out the whiteboxing process substantially)

alt text

(geometry/brushes left, static mesh on the right)

Product Version: UE 4.21
Tags:
more ▼

asked Feb 23 '19 at 04:27 PM in Using UE4

avatar image

DevSirTimothy
1 1

avatar image DevSirTimothy Feb 25 '19 at 01:24 PM

Consulted a friend who teaches Unreal and finally came up with a solution! The problem is with the way the UV's are assigned when converting the geometry brushes to a static mesh.

Fix: - Double click the created static mesh in the content browser - Change lightmap coordinate index to 1 (search or scroll down to general settings in the details window) - Change minimum lightmap resolution in LOD0 to something higher (e.g. 512) - Change lightmap resolution in general settings to something higher (e.g. 512) - Apply and save your changes - Build the lighting again

You can use any resolution you'd like, though 512 should be more than enough for whiteboxing.

We tried shifting around the Source and Destination lightmap index first, but that wouldn't budge at all. So ignore that, leave it on its default and just change the Lightmap Coordinate index in the general settings.

I hope this helps someone else that's facing the same problem :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question