x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

REPOST: Level Opens, And Character Isn't Controllable

Hello! I’ve been using the Main Menu UMG system and cannot get my menu to connect to my level. When a start game button is pushed (the blueprint is just “When Clicked” — “Open Level”— “Remove Parent”) the first level opens, but the character cannot be moved. I’ve tried changing game modes but to no progress. My demo is due very soon, and what seems like a simple problem is ruining everything. I’ve never experienced this in any other game I’ve made, and would love to have some assistance! Thank you!

Product Version: UE 4.21
Tags:
more ▼

asked Feb 25 '19 at 02:46 PM in Using UE4

avatar image

The_Catster
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Remove from parent before opening the level might help.

Also make sure you add a small delay node in the level blueprint as it opens. It's very common that without a delay node the setup just fails because of the order of how things happen.

more ▼

answered Feb 25 '19 at 03:05 PM

avatar image

Crowley Caine
683 8 10 15

avatar image The_Catster Feb 25 '19 at 03:16 PM

Thank you. I'll try this out when I can access Unreal Engine, and I'll update whether or not this was answered.

avatar image The_Catster Mar 09 '19 at 06:43 PM

I am so sorry for answering much later. I tried this, and it did not work. The screen loads up, and the character cannot be controlled.

avatar image Crowley Caine Mar 09 '19 at 06:45 PM

Alright. If you open up the character blueprint while playing when the character is not responding, is it receiving input from you at all?

avatar image The_Catster Mar 09 '19 at 07:02 PM

No. Not at all.

avatar image Crowley Caine Mar 09 '19 at 07:16 PM

Well you're already starting to narrow down on the problem then. On level load and when the character is supposed to be receiving input, have you tried adding the node "Set input mode game only"? Could fix it. For example on level load.

avatar image The_Catster Mar 09 '19 at 07:18 PM

So I'll try that, but maybe I explained wrong. If I open the level on it's own, the character does work. It's only when going through the menu. But, again I'll try.

avatar image Crowley Caine Mar 09 '19 at 07:18 PM

I understood that. I think the issue is that you may have set input mode to ui only, but never set it back to game only afterwards.

avatar image The_Catster Mar 09 '19 at 07:22 PM

Holy s**t you are a magician! Thank you so much! That worked! I'm pretty sure that what you said is true, when I created the UMG stuff for the main menu I set it to UI only! Thanks!

avatar image Crowley Caine Mar 09 '19 at 07:27 PM

Awesome! So glad that worked for you :-)

avatar image The_Catster Mar 09 '19 at 07:28 PM

Can I ask you a new question? I'm not sure if this forum has DM functionality.

avatar image Crowley Caine Mar 09 '19 at 07:37 PM

Go ahead. Can't guarantee I have an answer for it.

avatar image The_Catster Mar 09 '19 at 07:38 PM

Thanks. So, I have a resort model I got from Turbo Squid or something. I opened it in Max, and realized it didn't have a solid bottom, so when I import the FBX into Unreal my character just walks through it. Is there any way to make the floor a "floor" so that the character doesn't sink through?

avatar image Crowley Caine Mar 09 '19 at 07:46 PM

Collisions eh? Yeah, been having a rather lengthy go at those myself lately.

You have multiple avenues of approach here. One is to cheat and add an invisible floor that you can be 100% sure blocks your character.

Another is to first check the collisions in your character blueprint. Worldstatic should always be set to block. Then check the collisions in your model, they should block whatever your character is set to (usually the capsule is set to pawn).

I use Maya instead of Max myself so I can't really help you with 3DMax stuff specifically. But what I can definitely tell you is that on importing the scene you want to have a good look at collision settings.

I would recommend going into the static mesh objects for the floor and double check the collision settings there. A floor should always be block all, unless you have some reason for letting certain objects pass through them.

avatar image The_Catster Mar 09 '19 at 07:48 PM

I'll try that now. Yeah, I'm a Maya (and Blender) user as well, so that's why I was lost on this model. The issue with putting an invisible floor is that the model has stairs, and slopes, so it's not even.

avatar image Crowley Caine Mar 09 '19 at 07:51 PM

Yeah I wouldn't recommend it. Unless of course you have enemy AI that is supposed to traverse it while the level is unloaded via streaming. In which case you would need it anyway.

Collision can be a bit of a b**h to work with to be honest, keeping track of the channels isn't always so easy. Static meshes that cause no collision can be a major headache. I'd google that if anything "Static mesh has no collision".

avatar image The_Catster Mar 09 '19 at 07:53 PM

Ok, I'll try that as well.

avatar image Crowley Caine Mar 09 '19 at 07:56 PM

Open up the static mesh and go here: alt text

coll.png (21.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question