Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Framerate much lower in packaged build on Oculus for TextureRenderTarget2D for spectator camera

This issue have been reported as UE-70352. https://issues.unrealengine.com/issue/UE-70352

Below is a description to reproduce the error as the description on issue tracker is incomplete.


I tried to implement a spectator for my app by using TextureRenderTarget2D and discovered a weird bug. Everything works fine in the editor, BUT as soon as I package my project the frame rate drops really low (<15fps, sometimes less than 5 fps).

This is a bug related to Oculus somehow, because when I try running the packaged project with my HTC Vive everything works as expected.

Steps to reproduce:

  1. Start a new project with starter content.

  2. Check "Start in VR" in project settings.

  3. Add a TextureRenderTarget2D to the project, set the size to 1920x1080.

  4. Open level blueprint and add the following to "Begin Play" event:

    • "Set spectator screen mode" and set it to "Texture"

    • "Set spectator screen texture" and set it to our TextureRenderTarget2D.

  5. Add a "SceneCapture2D" to the project and set its target texture to our TextureRenderTarget2D and its capture source to "Final color"

  6. Package the project

The frame rate will be fine inside the editor. But the frame rate for the packaged project will be very low. It becomes very visible when turning the head from side to side.

The bug have been present since version 4.19 (at least) and is still present in the 4.22 preview version.

Product Version: UE 4.22 Preview
more ▼

asked Mar 01 '19 at 01:19 PM in VR

avatar image

6 1

avatar image Bedhead7 3 days ago

I can confirm this bug in 4.22. I am not certain the bug is actually low frame rate though. For me I am achieving 60+fps in a packaged build with a scenecapture2D, but my VR headset will never lock at 45fps with ASW. It's like the scenecapture2D is preventing the headset from locking the FPS at 45 or 90. I have tried all the smooth frame rate options to no avail. r.vsync 1 also does not fix the issue

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question