x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Join Session Succeeds but Screen Never Changes

Hello,

I've been developing a game and testing it on LAN using the Null online subsystem. Until recently I was able to host on my Mojave Mac and join and play on my Windows 10 PC by right-clicking the .uproject and clicking "Launch Game".

Now when I host on the Mac, and join on the PC, the success pin on the Join Session node fires, but the screen on the client never changes to the level that the Mac has open. After some time, the client reloads its main menu. It never seems to actually join the session.

If I host on the PC, and join on the Mac, everything works as expected.

Both computers have all the latest operating system updates.

Please let me know if you have any ideas what might have caused this loss of functionality.

Thanks.

Product Version: UE 4.21
Tags:
more ▼

asked Mar 03 '19 at 01:21 PM in Using UE4

avatar image

MC1RScorpion
10 3 3 5

avatar image MC1RScorpion Mar 03 '19 at 07:14 PM

This problem is definitely Mac-specific. I've tried connecting via direct IP, turning firewalls off, and a whole lot more.

What's strange is that it previously worked without issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Figured it out.

In DefaultEngine.ini I had the line:

"DefaultPlatformService=Null"

This was intended. However, from my experimentation with the Steam online subsystem I also still had a couple lines in this file that read:

[OnlineSubsystemSteam] bEnabled=true

Here I changed "true" to "false" and upon doing so was able to properly join the session being hosted on my Mac from my PC.

This seems to only cause problems on Mac and not Windows and previously had not caused any problems at all.

Cheers.

more ▼

answered Mar 03 '19 at 09:28 PM

avatar image

MC1RScorpion
10 3 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question