x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android / ARCore does not correctly deploy with 4.21

When creating a new 4.21 Project with ARCore and deplyoy it I have severalt problems, which I've solved the last days, I whould share my solutions with you:

  1. In the Project Settings I can't accept the Android SDK Licens. When packaging the Android APK with gradle it is complainning about not having accepted the SDK License. "Error: License not accepted. SDK License must be accepted in the ...."

  2. When I package it with ANT it gets packaged and I can deploy. When having build a ARCore App it crashes on start. Running "adb -d logcat" gives me errors about not finding a arcore sdk c file "unreal engine dlopen failed: library libarcore_sdk_c.so not found"

  3. Packaging with Gradle crashes with

LogPlayLevel Error .... .gradle\caches\transforms\ ......

LogPlayLevel Error: error: failed linking references.

Product Version: UE 4.21
Tags:
more ▼

asked Mar 06 '19 at 09:29 AM in Packaging & Deployment

avatar image

Adnoh
240 6 13 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Solutions:

  1. Edit File "path\to\your\NVPACK\android-sdk-windows\licenses\android-sdk-license" - in my case there was a blank line in front of the the license id. Remove it so it only contains the license id. Replace your Engine/Source/Third Party/Android/package.xml with the newer one https://github.com/EpicGames/UnrealEngine/blob/4.22/Engine/Source/ThirdParty/Android/package.xml to make gradle work again

  2. You MUST package with Gradle. ARCore is not bundled with ANT.

  3. Don't choose your latest SDK/NDK in project settings. On my machine it works fine with "android-21"

more ▼

answered Mar 06 '19 at 09:36 AM

avatar image

Adnoh
240 6 13 17

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had the same problem. I found that if you have Unreal Studio plug in activated can get trouble on android package. Work form me.

more ▼

answered Apr 12 '19 at 10:22 AM

avatar image

Pipps
6 2

avatar image Viperpog Apr 13 '19 at 01:29 AM

Thank you so much, I was trying a entire day make this template work, and only turning off Unreal Studio Plugins worked!!! Love you Pipps <3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, Does that link expired?

more ▼

answered Mar 22 '19 at 10:18 AM

avatar image

omex
6 1

avatar image Adnoh Mar 22 '19 at 11:38 AM

no but you need github access to unreal engine source code and be logged in to github

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question